Issues with Mac Studio Launch

Four Stars

Issues with Mac Studio Launch

My Java directory is pointing to 1.8... It is the JDK version.   But when the click on TOS_BD-macosx-cocoa it errors out due to JVM issues. 

 

Error:

java.lang.RuntimeException: No application id has been found. 

Top of the log

!SESSION 2017-12-04 09:08:30.677 -----------------------------------------------
eclipse.buildId=unknown
java.version=9.0.1
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments: -keyring /Users/precocity/.eclipse_keyring -showlocation
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/precocity/.eclipse_keyring -showlocation

 

 

I have tried to follow the instructions and set the Java_Home to default to 1.8, but Talend studio still trying to use 1.9 according to top of the log. I thought that is the problem.

 

My Mac's Java. 

echo $JAVA_HOME

/Library/Java/JavaVirtualMachines/jdk1.8.0_152.jdk/Contents/Home

Moderator

Re: Issues with Mac Studio Launch

Hello,

Have you already tried to add the previously defined JAVA_HOME variable to the Path environment variable.

  • Example: <PathVariable>;%JAVA_HOME%\bin.

Additionally, if setting the JAVA HOME fails add the following line in the .ini file (example: TOS_BD-macosx-cocoa.ini) for studio:

-vm path to java bin

Feel free to let us know if it is OK with you.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Issues with Mac Studio Launch

I still get an error in the log file.

 

Terminal Result:

java -version

java version "1.8.0_152"

Java(TM) SE Runtime Environment (build 1.8.0_152-b16)

Java HotSpot(TM) 64-Bit Server VM (build 25.152-b16, mixed mode)

One Star

Re: Issues with Mac Studio Launch

I am also facing the same issue.

Could you please elaborate how to add -vm to ini file?

Moderator

Re: Issues with Mac Studio Launch

Hello,

You can add the following line in the .ini file (example: Talend-Studio-win-x86_64.ini) for studio:

-vm path to java bin

 Example:

-vm C:\Program Files\Java\jdk1.8.0_65 \bin

Now your Talend Studio will use Java 1.8 version.

Feel free to let us know if it doesn't work for you.

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

Tutorial

Introduction to Talend Open Studio for Data Integration.

Definitive Guide to Data Integration

Practical steps to developing your data integration strategy.

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.