Four Stars

Issue when opening Talend Studio-win-x86_64

Hi, Our Talend was working fine ealier, but suddenly it would not open and throws the below error, can you please help me to find what is wrong?

 

!SESSION 2017-12-19 10:53:27.871 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_79
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.equinox.app 0 0 2017-12-19 10:53:29.587
!MESSAGE Product org.talend.rcp.branding.generic.product could not be found.

!ENTRY org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.motif.hpux.ia64_32_3.6.1.v3655c [95] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.win32.win32.x86_3.6.1.v3655c [109] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.solaris.sparc_1.1.1.R36x_v20100810 [137] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.gtk.linux.ppc64_3.6.1.v3655c [182] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.equinox.launcher.motif.aix.ppc_1.1.1.R36x_v20100810 [223] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.motif.linux.x86_3.6.1.v3655c [255] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.ui.carbon_4.0.100.M20100825-0800 [258] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.equinox.launcher.motif.linux.x86_1.1.1.R36x_v20100810 [267] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.equinox.launcher.cocoa.macosx_1.1.1.R36x_v20100810 [310] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.gtk.linux.ppc_3.6.1.v3655c [314] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.gtk.linux.x86_3.6.1.v3655c [398] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.gtk.solaris.sparc_3.6.1.v3655c [418] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.cocoa.macosx_3.6.1.v3655c [428] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810 [436] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.ui.cocoa_1.0.2.M20100825-0800 [438] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.equinox.launcher.win32.win32.x86_1.1.1.R36x_v20100810 [447] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.motif.aix.ppc_3.6.1.v3655c [456] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.solaris.x86_1.1.1.R36x_v20100810 [501] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.gtk.solaris.x86_3.6.1.v3655c [511] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.linux.x86_1.1.1.R36x_v20100810 [556] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.linux.ppc_1.1.1.R36x_v20100810 [589] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.equinox.launcher.motif.hpux.ia64_32_1.1.1.R36x_v20100810 [598] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.cocoa.macosx.x86_64_3.6.1.v3655c [631] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.1.R36x_v20100810 [652] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.equinox.launcher.carbon.macosx_1.1.1.R36x_v20100810 [680] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.carbon.macosx_3.6.1.v3655c [763] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-12-19 10:53:29.680
!MESSAGE Bundle org.eclipse.swt.gtk.linux.x86_64_3.6.1.v3655c [764] was not resolved.

!ENTRY org.eclipse.osgi 4 0 2017-12-19 10:53:29.680
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
at org.eclipse.equinox.launcher.Main.main(Main.java:1383)

3 REPLIES
Moderator

Re: Issue when opening Talend Studio-win-x86_64

Hello,

For v6 of Talend products JDKv1.8 is required. Could you please indicate on which talend build version you got this issue? 

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Issue when opening Talend Studio-win-x86_64

That's correct. You have to have JDK 8 if you are using Talent studio 6.4. Please reinstall JDK and you cannot have latest JDK 9 version. Also setup system variables for JDK as mentioned in the guide.

Moderator

Re: Issue when opening Talend Studio-win-x86_64

Hello,

Is there any update for your issue when opening Talend Studio-win-x86_64? Feel free to post your issue here.

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.