Five Stars

Installing TalendToolsStudio on Sierra

My OS: macOS High Sierra ver 10.13.1

Installing: TalendToolsStudio-6.4.1

 

Always getting the same error:

------

Error copying file from /Applications/TalendToolsStudio-6.4.1/studio/SSLKeystore to /Applications/TalendToolsStudio-6.4.1/studio/Talend-Studio-macosx-cocoa.app/Contents/MacOSSmiley Very Happyestination not writable

------

Thanks for you replies

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator

Re: Installing TalendToolsStudio on Sierra

Hello,

So far, OSX High Sierra (10.13.1) is not in the supported list of compatible Operation System, that means we did not do any testing on OSX High Sierra (10.13.1). Have you tried to install studio on a supported OS to see if it works?

Please have a look at this online document about: TalendHelpCenter:Compatible Operating Systems

Here is the related jira issue:https://jira.talendforge.org/browse/TUP-18888

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
12 REPLIES
Moderator

Re: Installing TalendToolsStudio on Sierra

Hello,

Are you using talend installer to install your studio? Can you manually create folder /Applications/TalendToolsStudio-6.4.1/studio/Talend-Studio-macosx-cocoa.app to see if the installation can be done successfully?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Installing TalendToolsStudio on Sierra

Indeed

mkdir /Applications/TalendToolsStudio-6.4.1/studio/Talend-Studio-macosx-cocoa.app/Contents

helped to finish the installation but then impossible to start the application.

/Applications/TalendToolsStudio-6.4.1/studio/Talend-Studio-macosx-cocoa.app

Double-click on  generates an error

Moderator

Re: Installing TalendToolsStudio on Sierra

Hello,

So far, OSX High Sierra (10.13.1) is not in the supported list of compatible Operation System, that means we did not do any testing on OSX High Sierra (10.13.1). Have you tried to install studio on a supported OS to see if it works?

Please have a look at this online document about: TalendHelpCenter:Compatible Operating Systems

Here is the related jira issue:https://jira.talendforge.org/browse/TUP-18888

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Installing TalendToolsStudio on Sierra

Thank you for your answer, i was struggling for nothing ;(
Works obviously for Sierra 10.12 but not for 10.13 ...
Thanks anyway
Four Stars

Re: Installing TalendToolsStudio on Sierra

I also ran into the same error message when trying to install on macOS 10.13.2.

error copying file from /Applications/TalendToolsStudio-6.4.1/studio/SSLKeystore to /Applications/TalendToolsStudio-6.4.1/studio/Talend-studio-mocosx-cocoa.app/Contents/MacOS :Destionation not writable

Anyone have any tricks to successfully install on macOS 10.13 ? 

Also, it looks like the Jira ticket for this thread is more related to a JVM issue after install. This error message above is specific to the install on macOS 10.13. Should it be treated in a separate Jira ticket?

I've attached the bitrock_installer logs produced when running the installer on my mac. The error message is triggered once the "Unpacking files" stage is reached. 

 

Thanks!

-Josh

Moderator

Re: Installing TalendToolsStudio on Sierra

Hi,

So far, supported compatible platform for MAC are OS X 10.12 Sierra, OS X 10.11 El Capitan and OS X 10.10 Yosemite on talend studio V 6.4.1

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Installing TalendToolsStudio on Sierra

How come this was marked as a solution?

Anyway, same problem with me. I have MacOS High Sierra 10.3.3 and trying to install Talend Studio 6.4.1.

After getting the same problem of cannot copy Keystore to the .app folder, I created the folder manually and continued installing.

mkdir -p Talend-Studio-macosx-cocoa.app/Contents/MacOS

However, when I try running app I'm getting

You can’t open the application “Talend-Studio-macosx-cocoa” because it may be damaged or incomplete.

BTW, java version is  1.8.0_66

Two Stars

Re: Installing TalendToolsStudio on Sierra

I am also facing same issue. So can someone please provide a solution here?
Five Stars

Re: Installing TalendToolsStudio on Sierra

If you can get access to the ZIP package instead of the OSX installer, just use the ZIP package.

Extract it, then run xattr on the folder:

xattr -c Talend-Studio-macosx-cocoa.app

What I'm not sure is which Java version works. Mine is 1.8.0_66, and I am able to open up the Studio.

Two Stars

Re: Installing TalendToolsStudio on Sierra

This got me closer on macOS High Sierra 10.13.3. I get the Talend Open Studio splash screen followed by the license agreement screen, but it hangs there and can't accept to continue. 

Two Stars

Re: Installing TalendToolsStudio on Sierra

I'm on High Sierra 10.13.3 and was able to get Talend Open Studio 6.5.1.20180116_1512 running. 

 

My default JRE is 1.8.0_161, but I had to force Talend to use previously installed version 1.8.0_121. 

 

  1. Run this on the .app file: 
    xattr -c [path to TOS_DI-macosx-cocoa.app]
  2. Right-click the .app and "Show Package Contents"
  3. Edit Contents/info.plist
  4. Add this string: <string>-vm</string><string>/Library/Java/JavaVirtualMachines/jdk1.8.0_121.jdk/Contents/Home/bin/java</string>

Apparently this is more of a Java issue than an OS issue. 

See bug tracker here: https://jira.talendforge.org/browse/TUP-18888?_ga=2.57167981.677213691.1522790430-1499068233.1519773...

Five Stars

Re: Installing TalendToolsStudio on Sierra

Check your Java version, from what i read in https://help.talend.com/reader/pnDa19MHCwcQqU6Dqeyxdg/QiBwsPB_OFS64lEACkDWEQ, it only supports Java 1.8 and 1.7.

 

If its not that, i'm not sure what's next