Four Stars

Installer for TOS DI does not work on Windows 10

I downloaded TOS_DI-20170623_1246-V6.4.1.zip to install Talend Open Studio for Data Integration. 

I'm running a 64bit Win10 (Version 1703 Build 15063.726)

I have Java9 installed with JAVA_HOME set to the appropriate directory

java version "9"
Java(TM) SE Runtime Environment (build 9+181)
Java HotSpot(TM) 64-Bit Server VM (build 9+181, mixed mode)

When I try to run the TOS installer it fails with the following log (cropped to the first few error messages):

!SESSION 2017-12-11 15:58:50.611 -----------------------------------------------
eclipse.buildId=unknown
java.version=9
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Command-line arguments:  -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.jdt.launching.macosx 4 0 2017-12-11 15:59:12.853
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.macosx [326]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.jdt.launching.ui.macosx 4 0 2017-12-11 15:59:12.863
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.ui.macosx [328]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.common.ui.runtime 4 0 2017-12-11 15:59:12.868
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.common.ui.runtime [480]
  Unresolved requirement: Import-Package: org.eclipse.swt.graphics
    -> Export-Package: org.eclipse.swt.graphics; bundle-symbolic-name="org.eclipse.swt.gtk.linux.ppc64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.gtk.linux.ppc64 [406]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64))"
  Unresolved requirement: Import-Package: org.eclipse.swt.events
    -> Export-Package: org.eclipse.swt.events; bundle-symbolic-name="org.eclipse.swt.win32.win32.x86"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.win32.win32.x86 [421]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86))"
  Unresolved requirement: Require-Bundle: org.talend.commons.runtime
    -> Bundle-SymbolicName: org.talend.commons.runtime; bundle-version="6.4.1.20170623_1246"
       org.talend.commons.runtime [482]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
  Unresolved requirement: Import-Package: org.eclipse.swt.custom
    -> Export-Package: org.eclipse.swt.custom; bundle-symbolic-name="org.eclipse.swt.gtk.solaris.x86"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.gtk.solaris.x86 [419]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=solaris) (osgi.arch=x86))"
  Unresolved requirement: Import-Package: org.eclipse.swt
    -> Export-Package: org.eclipse.swt; bundle-symbolic-name="org.eclipse.swt.cocoa.macosx"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.cocoa.macosx [395]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) )"
  Unresolved requirement: Import-Package: org.eclipse.swt.widgets
    -> Export-Package: org.eclipse.swt.widgets; bundle-symbolic-name="org.eclipse.swt.cocoa.macosx.x86_64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.cocoa.macosx.x86_64 [394]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (osgi.arch=x86_64) )"
  Unresolved requirement: Import-Package: org.eclipse.swt.layout
    -> Export-Package: org.eclipse.swt.layout; bundle-symbolic-name="org.eclipse.swt.gtk.solaris.sparc"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.gtk.solaris.sparc [417]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=solaris) (osgi.arch=sparc))"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

(full log attached)

 

what can I do?!

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator

Re: Installer for TOS DI does not work on Windows 10

Hello,

 For v6 of Talend products Java 8 is required instead of Java 9.

Ensure proper version of JDK is installed in your machine. For more information, please refer to this online document:TalendHelpCenter:Java

Best regards

Sabrina

 

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
3 REPLIES
Moderator

Re: Installer for TOS DI does not work on Windows 10

Hello,

 For v6 of Talend products Java 8 is required instead of Java 9.

Ensure proper version of JDK is installed in your machine. For more information, please refer to this online document:TalendHelpCenter:Java

Best regards

Sabrina

 

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Installer for TOS DI does not work on Windows 10

I installed version 7 and got the same errors.  I have Java JRE 10.0.  What version should I be using for Talend 7.0?

Moderator

Re: Installer for TOS DI does not work on Windows 10

Hello,

Please refer to online document about:TalendHelpCenter:Compatible Java Environments for V 7.0

The recommended version is oracle 8.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.