One Star

Installation on MacOS X.4.10 problem

Hi all,
I am just new to talend, but no to ETLs. I'd love to discover what talent is about, but while trying to install it on my macbookpro, I am having problems to run it, either with production or 2.2.0RC1. Basically, it does not start at all the app if clicking on the .app icon.
If I try to start form startup.jar though, I have these errors:
EXC_BAD_ACCESS (0x0001)
KERN_INVALID_ADDRESS (0x0001) at 0x72476164
Thread 1 Crashed:
0 CGClipStackCreateMutableCopy + 223
1 maybeCopyClipState + 68
2 CGGStateClipToPath + 278
3 doClip + 128
4 HIView::RecursiveDrawComposited(__HIShape const*, unsigned long, HIView*, CGContext*, unsigned char) + 655
5 HIView::RecursiveDrawComposited(__HIShape const*, unsigned long, HIView*, CGContext*, unsigned char) + 1276
6 HIView:Smiley Very HappyrawComposited(short, OpaqueGrafPtr*, __HIShape const*, unsigned long, HIView*, CGContext*) + 601
7 HIView:Smiley Very Happyraw(short, OpaqueGrafPtr*, unsigned long) + 75
8 HIView::Render(unsigned long, CGContext*) + 45
9 _ShowHideWindows + 504

Then if I restart it:
EXC_BAD_ACCESS (0x0001)
KERN_PROTECTION_FAILURE (0x0002) at 0x00000008
Thread 2 Crashed:
0 JVM_RaiseSignal + 550198
1 JVM_RaiseSignal + 546893
2 JVM_RaiseSignal + 694452
3 JVM_RaiseSignal + 696064
4 JVM_RaiseSignal + 336508
5 JVM_GetLastErrorString + 9863
6 JNI_CreateJavaVM_Impl + 53236
7 JNI_CreateJavaVM_Impl + 53061
8 JNI_CreateJavaVM_Impl + 52845
9 _pthread_body + 84
Or sometimes I got the registration window but I can't write in it...
My Java version is:
java version "1.5.0_07"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-164)
Java HotSpot(TM) Client VM (build 1.5.0_07-87, mixed mode, sharing)
Many thanks for your help in this.
Remy
13 REPLIES
One Star

Re: Installation on MacOS X.4.10 problem

java version "1.5.0_07"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-164)
Java HotSpot(TM) Client VM (build 1.5.0_07-87, mixed mode, sharing)
chmod +x TOS-All-r6191-V2.2.0GA/TalendOpenStudio-macosx-carbon.app/Contents/MacOS/TalendOpenStudio-macosx-carbon
and its good ...
One Star

Re: Installation on MacOS X.4.10 problem

Works... many thanks!
One Star

Re: Installation on MacOS X.4.10 problem

I had the same problem with Leopard, Mac OS X 10.5.1 and this fix worked, many thanks.
Not applicable

Re: Installation on MacOS X.4.10 problem

Hi Ross,
did you have issues with fonts smaller or bigger than on windows ?
One Star

Re: Installation on MacOS X.4.10 problem

Had the same problem under Leopard. Thanks for the fix; works flawlessly!
One Star

Re: Installation on MacOS X.4.10 problem

I found a way to run TalenD 3.1 on the os X 10.5 in case the proposed fix given in the previous post does not solve the issue (as it was my case Smiley Wink.
After setting the execution right on the proper file as mentionned in previous post, open a terminal window and do the following command:
//provided you are in the TOS-All-r24830-V3.1.1 directory
open TalendOpenStudio-macosx-carbon.app/Contents/MacOS/TalendOpenStudio-macosx-carbon
it just launch the studio. I had no time to identify the origin of the problem, but it works.
alternatively, you can create a short shell file, in which you will include that command line to launch the app in a more pleasant and convenient way.

Phil.
One Star

Re: Installation on MacOS X.4.10 problem

Thanks Philippe! I was not able to get the chmod fix to work either on 10.5.7 but your "open" solution did the trick!
One Star

Re: Installation on MacOS X.4.10 problem

With OS X 10.6.1 starting TOS-All-r29643-V3.2.0RC1 with the open-command works fine as well. Thank you.
Still, being able to double click on a nice icon would be a little smoother ;-)
One Star

Re: Installation on MacOS X.4.10 problem

When opening a projekt with 10.6.1, unfortunately, the TOS throws the following error:
org.eclipse.swt.SWTException: Invalid thread access
at org.eclipse.swt.SWT.error(SWT.java:3777)
at org.eclipse.swt.SWT.error(SWT.java:3695)
at org.eclipse.swt.SWT.error(SWT.java:3666)
at org.eclipse.swt.widgets.Display.error(Display.java:1126)
at org.eclipse.swt.widgets.Display.checkDevice(Display.java:627)
at org.eclipse.swt.graphics.Device.getDPI(Device.java:370)
at org.eclipse.swt.graphics.Font.init(Font.java:398)
at org.eclipse.swt.graphics.Font.<init>(Font.java:171)
at org.talend.designer.core.ui.preferences.PreferenceInitializer.initializeDefaultPreferences(Unknown Source)
at org.eclipse.core.internal.preferences.PreferenceServiceRegistryHelper.runInitializer(PreferenceServiceRegistryHelper.java:276)
at org.eclipse.core.internal.preferences.PreferenceServiceRegistryHelper.applyRuntimeDefaults(PreferenceServiceRegistryHelper.java:130)
at org.eclipse.core.internal.preferences.PreferencesService.applyRuntimeDefaults(PreferencesService.java:367)
at org.eclipse.core.internal.preferences.DefaultPreferences.applyRuntimeDefaults(DefaultPreferences.java:163)
at org.eclipse.core.internal.preferences.DefaultPreferences.loadDefaults(DefaultPreferences.java:236)
at org.eclipse.core.internal.preferences.DefaultPreferences.load(DefaultPreferences.java:232)
at org.eclipse.core.internal.preferences.EclipsePreferences.create(EclipsePreferences.java:307)
at org.eclipse.core.internal.preferences.EclipsePreferences.internalNode(EclipsePreferences.java:543)
at org.eclipse.core.internal.preferences.EclipsePreferences.node(EclipsePreferences.java:662)
at org.eclipse.core.internal.preferences.AbstractScope.getNode(AbstractScope.java:38)
at org.eclipse.core.runtime.preferences.DefaultScope.getNode(DefaultScope.java:68)
at org.eclipse.ui.preferences.ScopedPreferenceStore.getDefaultPreferences(ScopedPreferenceStore.java:250)
at org.eclipse.ui.preferences.ScopedPreferenceStore.getPreferenceNodes(ScopedPreferenceStore.java:285)
at org.eclipse.ui.preferences.ScopedPreferenceStore.internalGet(ScopedPreferenceStore.java:475)
at org.eclipse.ui.preferences.ScopedPreferenceStore.getBoolean(ScopedPreferenceStore.java:387)
at org.talend.designer.core.ui.projectsetting.StatsAndLogsHelper.statsAndLogsParametersTitlePart(Unknown Source)
at org.talend.designer.core.ui.projectsetting.StatsAndLogsHelper.createStatsAndLogsParameters(Unknown Source)
at org.talend.designer.core.ui.projectsetting.ProjectSettingManager.createStatsAndLogsElement(Unknown Source)
at org.talend.designer.core.DesignerCoreService.createStatsLogAndImplicitParamter(Unknown Source)
at org.talend.repository.model.ProxyRepositoryFactory.logOnProject(Unknown Source)
at org.talend.repository.ui.login.LoginDialog$1.run(Unknown Source)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)

Ignoring the error Eclipse starts fine.
When creating a new Job Design I receive a org.eclipse.swt.SWTException.
Any hints how I can solve this problem? Is there a chance to get this running flawlessly?
One Star

Re: Installation on MacOS X.4.10 problem

Hello all,
I just dl the last version 3.2.1 of talend open studio.
There is still the same problem. (application doesn't launch and we get an error message which tell about corrupted application)
I did the chmod command, no changes.
When I use the open command, the application starts.
But i get the swt error when i want open a project.

Any idea?

Thanks for your help!!
One Star

Re: Installation on MacOS X.4.10 problem

Hello all,
if you can't run tos by clicking on the .app file (error message "...incomplete/corrupt..."), maybe I can help Smiley Happy
I reported this problem as a bug and my workaround for that problem - so hopefully this problem will be fixed in one of the next releases.
Just take a look at http://www.talendforge.org/bugs/view.php?id=10289
One Star

Re: Installation on MacOS X.4.10 problem

Running
Mac OS X 10.6.2 (10C540)
Kernel Version: Darwin 10.2.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Computer Name: OCTRI?s MacBook Pro
User Name: xxx
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: No
Time since boot: 4 days 13:01
using java version
java version "1.6.0_15"
Java(TM) SE Runtime Environment (build 1.6.0_15-b03-219)
Java HotSpot(TM) 64-Bit Server VM (build 14.1-b02-90, mixed mode)

With setting the chmod +x and using open... I still get the error ( yes eclipse works fine.. not that I use) .
ERROR: Invalid thread access
org.eclipse.swt.SWTException: Invalid thread access
at org.eclipse.swt.SWT.error(SWT.java:3777)
at org.eclipse.swt.SWT.error(SWT.java:3695)
at org.eclipse.swt.SWT.error(SWT.java:3666)
Community Manager

Re: Installation on MacOS X.4.10 problem

Hello greggh
ERROR: Invalid thread access
org.eclipse.swt.SWTException: Invalid thread access

Read the related 4132.
Best regards

shong
----------------------------------------------------------
Talend | Data Agility for Modern Business