One Star

Installation issue on Mac OS

Hi,

 

I am facing the following issues which one of them resolved on my own. 

 

1. Could not open TOS_DI-macosx-cocoa and had to run 

xattr -c TOS_DI-macosx-cocoa.app 

2. Now after that I am getting the error To open “Talend Open Studio for Data Integration” you need to install the legacy Java SE 6 runtime.

 

I am running MacOs Sierra version 10.12.5 

surely I dont need version 6 now do I ?

 

Thanks for your help. 

 

Regards

 

Ajith

  • Talend Installer
9 REPLIES
Moderator

Re: Installation issue on Mac OS

Hi,

What's talend build version you are using? And what's your JDK version? More information will be preferred.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Nine Stars

Re: Installation issue on Mac OS

 

Generally - I never have the problem with Talend on Mac if NOT use build  unarchiver
I use Archiver - and never have this problem (repeated many, many times)

 

Screen Shot 2017-07-03 at 9.46.55 PM.png

-----------
Moderator

Re: Installation issue on Mac OS

Hi Ajith,

Are you using third-party ZIP extractor or the built-in OS X zip extractor?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Installation issue on Mac OS

Hi!

 

I have downloaded v6.4.0 and I am using OSX  Sierra v10.12.5. My java version is 1.8.0_131.

 

After I unzip the downloaded file, I click on the cocoa app, and I get the following error:

 

The TOS_BD-macosx-cocoa executable launcher was unable to locate its companion shared library.

 

Any help?

Thanks

Arya

 

Moderator

Re: Installation issue on Mac OS

Hi,

It looks like OS X default unzip did not extract properly. Could you please try to delete the previous set of files and then re-extract using other extractor to see if it works?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Installation issue on Mac OS

I'm also experiencing this issue. I just downloaded the 20170623_1246-V6.4.1 zip file and extracted it. When I open the .app file, I get the error saying that I need Java 1.6. When I install Java 1.6, it clears that error but then throws a new error saying that I need JRE 1.8...

Moderator

Re: Installation issue on Mac OS

Hello,

Java 8 is currently the recommended Java version for all Talend products and modules since v6.0.

Have you tried to install JDK 1.8 in your Mac OS to see if this issue still repro or get a new error, such as," TOS_BD-macosx-cocoa executable launcher was unable to locate its companion shared library."?

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Installation issue on Mac OS

I have already installed Java 8. (A visit to the Java verifier shows Java 8 update 144 installed.) Any thoughts for where to look next?

 

Cheers,

Sean

Moderator

Re: Installation issue on Mac OS

Hello,

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.