Four Stars

Installation errors on Mac OS X Sierra

I have a client that is installing TOS DI 7.0.1 on OS X Sierra. I've gone through the other solutions and they are not working. 

First thing I noticed was that the install guide was a 6.x version - Talend needs to update this.

We unpacked with Keka since other threads said the Mac unzipper doesn't work properly and fails silently. But this should be in the install docs if true.

When trying to run, the error is:

 

  • The TOS_DI-macosx-cocoa executable launcher was unable to locate it's companion shared library.

 

There appears to be some xattr command you need to run, but we tried that:

 

xattr -c TOS_DI-macosx-cocoa.app
or
xattr -c *

in the unpacked directory. We still get this error when it launches. It goes on and on with other modules, but I truncated it for brevity:

!SESSION 2018-06-09 17:51:02.615 -----------------------------------------------
eclipse.buildId=unknown
java.version=10.0.1
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments:  -keyring /Users/seanashbrook/.eclipse_keyring -showlocation
Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -keyring /Users/seanashbrook/.eclipse_keyring -showlocation

This is a continuation of log file /Applications/talend/TOS_DI-20180411_1414-V7.0.1/configuration/1528591862968.bak_0.log
Created Time: 2018-06-09 17:51:28.561

!ENTRY org.talend.presentation.onboarding.nl 2 0 2018-06-09 17:51:28.594
!MESSAGE Could not resolve module: org.talend.presentation.onboarding.nl [711]
  Unresolved requirement: Fragment-Host: org.talend.presentation.onboarding
    -> Bundle-SymbolicName: org.talend.presentation.onboarding; bundle-version="7.0.1.20180411_1414"; singleton:="true"
       org.talend.presentation.onboarding [716]
         Unresolved requirement: Require-Bundle: org.talend.libraries.jackson
           -> Bundle-SymbolicName: org.talend.libraries.jackson; bundle-version="7.0.1.20180411_1414"; singleton:="true"
              org.talend.libraries.jackson [656]
                Unresolved requirement: Require-Bundle: com.fasterxml.jackson.core.jackson-databind; bundle-version="2.9.4"; visibility:="reexport"
                  -> Bundle-SymbolicName: com.fasterxml.jackson.core.jackson-databind; bundle-version="2.9.4"
                     com.fasterxml.jackson.core.jackson-databind [15]
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

I don't see any other solutions. Thank you kindly.

 

1 REPLY
Moderator

Re: Installation errors on Mac OS X Sierra

Hello,

We are not yet targeting java 10. Could you please use java 8 instead to see if it works?

Here is online documentation about:TalendHelpCenter:Compatible Java Environments.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.