Four Stars

Installation Error - Version 6.3.1 - Linux Centos 7

I am trying to install Talend Open Studio 6.3.1 in Centos 7. I have downloaded the TOS and able to access the same in windows machine but the same I want to install in Centos 7. 

 

Could anyone please help me with it.

 

Thanks.

  • Talend Installer
4 REPLIES
Highlighted
Employee

Re: Installation Error - Version 6.3.1 - Linux Centos 7

Hi

 

Please follow the installation guide here https://help.talend.com/reader/xzh5eJ75p8A0UdG2ip55Cw/MDauhq9nl1m0FXZX~aHp9Q

And you did not mention the error?  Did you search the forum or jira system to find out if there is a workaround already?

 

Thanks,

Irshad

Four Stars

Re: Installation Error - Version 6.3.1 - Linux Centos 7

Thanks for replying.

 

I have searched for the installation steps for Talend Big Data and not for Talend Open Studio.

and the link that you have provided has all the steps mentioned. 

Will let you know if I face any issue.

 

Thanks

Four Stars

Re: Installation Error - Version 6.3.1 - Linux Centos 7

Hi Irshad,

 

Just now i tried installing TOS in the server following the steps mentioned in the link.

I am getting the below error. 

 

Kindly check and validate.

 

[root@UGAODSDEV01 TOS_BD-20161026_1219-V6.3.0]# ./TOS_BD-linux-gtk-x86.sh
./TOS_BD-linux-gtk-x86.sh: line 6: ./TOS_BD-linux-gtk-x86_64: Permission denied

 

Let me know if I need to check any other options.

 

Thanks

Four Stars

Re: Installation Error - Version 6.3.1 - Linux Centos 7

Hi,

 

I have followed all the steps and installed TOS in unix but now I am facing this issue. 

 

[root@INBNBHPC01496 TOS_BD-20161026_1219-V6.3.0]# ./start.sh
Unrecognized VM option 'UseStringDeduplicatio'
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

(TOS_BD-linux-gtk-x86_64:26279): Gdk-WARNING **: The GDK_NATIVE_WINDOWS environment variable is not supported in GTK3.
See the documentation for gdk_window_ensure_native() on how to get native windows.
No protocol specified

** (TOS_BD-linux-gtk-x86_64:26279): WARNING **: Could not open X display
TOS_BD-linux-gtk-x86_64: Cannot open display:
TOS_BD-linux-gtk-x86_64:
JVM terminated. Exit code=1
/usr/bin/java
-Xms512m
-Xmx1536m
-Dfile.encoding=UTF-8
-Dosgi.requiredJavaVersion=1.8
-XX:+UseG1GC
-XX:+UseStringDeduplicatio
-vmargs
-Xms40m
-Xmx500m
-XX:MaxPermSize=512m
-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/local/lib/xulrunner
-jar /TOS_BD-20161026_1219-V6.3.0/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /TOS_BD-20161026_1219-V6.3.0/TOS_BD-linux-gtk-x86_64
-name TOS_BD-linux-gtk-x86_64
--launcher.library /TOS_BD-20161026_1219-V6.3.0/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140603-1326/eclipse_1605.so
-startup /TOS_BD-20161026_1219-V6.3.0/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
--launcher.overrideVmargs
-exitdata d0004
-vm /usr/bin/java
-vmargs
-Xms512m
-Xmx1536m
-Dfile.encoding=UTF-8
-Dosgi.requiredJavaVersion=1.8
-XX:+UseG1GC
-XX:+UseStringDeduplicatio
-vmargs
-Xms40m
-Xmx500m
-XX:MaxPermSize=512m
-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/local/lib/xulrunner
-jar /TOS_BD-20161026_1219-V6.3.0/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar

 

 

could you please help me in solving this issue.

 

Thanks