One Star

Install of Talend Open Studio on Linux - Studio not Launching

Hi,
I'm a new user.  I tried to launch Talend Open Studio on Linux, but nothing's happening.  I'm not sure what I'm missing.  Any help please?  Thanks!!
CONTENTS OF THE DIRECTORY:
$ ls -ltr
total 536640
drwxrwxrwx. 11 cloud-user cloud-user      4096 Mar  2  2012 xulrunner
-rwxrwxrwx.  1 svtaleadm  svtaleadm        605 Jan 29 17:52 license.txt
-rwxrwxrwx.  1 svtaleadm  svtaleadm      14859 Jan 29 17:52 NOTICE.txt
-rwxrwxrwx.  1 svtaleadm  svtaleadm        263 Jan 29 17:52 TOS_DI-linux-gtk-x86.sh
-rwxrwxrwx.  1 svtaleadm  svtaleadm      68333 Jan 29 17:52 TOS_DI-linux-gtk-x86_64
-rwxrwxrwx.  1 svtaleadm  svtaleadm      52932 Jan 29 17:52 TOS_DI-linux-gtk-x86
-rwxrwxrwx.  1 svtaleadm  svtaleadm      64212 Jan 29 17:52 TOS_DI-linux-gtk-ppc
-rwxrwxrwx.  1 svtaleadm  svtaleadm        138 Jan 29 17:59 TOS_DI-linux-gtk-x86.ini
-rwxrwxrwx.  1 svtaleadm  svtaleadm        138 Jan 29 18:00 TOS_DI-linux-gtk-ppc.ini
-rwxrwxrwx.  1 svtaleadm  svtaleadm        139 Jan 29 18:00 TOS_DI-linux-gtk-x86_64.ini
LINUX VERSION:
$ uname -a
Linux tale 2.6.32-431.29.2.el6.x86_64 #1 SMP Sun Jul 27 15:55:46 EDT 2014 x86_64 x86_64 x86_64 GNU/Linux
CONTENTS OF THE .INI FILES:
$ cat TOS_DI-linux-gtk-x86.ini
-vmargs
-Xms256m
-Xmx768m
-XX:MaxPermSize=256m
-Dfile.encoding=UTF-8
-Dorg.eclipse.swt.browser.XULRunnerPath=</usr/tmp/TALSTUD/xulrunner>
$ cat TOS_DI-linux-gtk-x86_64.ini
-vmargs
-Xms512m
-Xmx1536m
-XX:MaxPermSize=512m
-Dfile.encoding=UTF-8
-Dorg.eclipse.swt.browser.XULRunnerPath=</usr/tmp/TALSTUD/xulrunner>
JAVA VERSION:
$ java -version
java version "1.7.0_75"
Java(TM) SE Runtime Environment (build 1.7.0_75-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.75-b04, mixed mode)
WHEN I TRY TO RUN THE SCRIPT, IT JUST RETURNS TO THE PROMPT:
$ ./TOS_DI-linux-gtk-x86.sh
8 REPLIES
Moderator

Re: Install of Talend Open Studio on Linux - Studio not Launching

Hi,
Is there any error log which is located in <Talend Studio installation path>/workspace/.metadata/.log?

Best regards
Sabrina

 
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Install of Talend Open Studio on Linux - Studio not Launching

Thanks for the quick reply.  I don't see any .metadata under the TALSTUD folder:
$ ls -la
total 536652
drwxrwxrwx.  3 root       root            4096 Jan 29 22:09 .
drwxrwxrwt.  6 root       root            4096 Jan 29 20:45 ..
-rw-rw-r--.  1 svtaleadm  svtaleadm        123 Jan 29 22:09 .eclipseproduct
-rwxrwxrwx.  1 svtaleadm  svtaleadm        605 Jan 29 17:52 license.txt
-rwxrwxrwx.  1 svtaleadm  svtaleadm      14859 Jan 29 17:52 NOTICE.txt
-rwxrwxrwx.  1 svtaleadm  svtaleadm      64212 Jan 29 17:52 TOS_DI-linux-gtk-ppc
-rwxrwxrwx.  1 svtaleadm  svtaleadm        138 Jan 29 18:00 TOS_DI-linux-gtk-ppc.ini
-rwxrwxrwx.  1 svtaleadm  svtaleadm      52932 Jan 29 17:52 TOS_DI-linux-gtk-x86
-rwxrwxrwx.  1 svtaleadm  svtaleadm      68333 Jan 29 17:52 TOS_DI-linux-gtk-x86_64
-rwxrwxrwx.  1 svtaleadm  svtaleadm        139 Jan 29 18:00 TOS_DI-linux-gtk-x86_64.ini
-rwxrwxrwx.  1 svtaleadm  svtaleadm        138 Jan 29 17:59 TOS_DI-linux-gtk-x86.ini
-rwxrwxrwx.  1 svtaleadm  svtaleadm        263 Jan 29 17:52 TOS_DI-linux-gtk-x86.sh
drwxrwxrwx. 11 cloud-user cloud-user      4096 Mar  2  2012 xulrunner
Moderator

Re: Install of Talend Open Studio on Linux - Studio not Launching

Hi,
Do your linux support for GUI? Have you tried to install Talend Open Studio by manually?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Install of Talend Open Studio on Linux - Studio not Launching

Hi,
I have not tried to install Talend Open Studio manually. Can you share steps please?  Thanks!!
One Star

Re: Install of Talend Open Studio on Linux - Studio not Launching

Hi,
So I downloaded the TOS install again.  Set up the .ini and tried to launch the studio.  This is the error I'm seeing in the .log.
Any ideas?  Thanks!!
$ vi .log
!ENTRY org.eclipse.osgi 4 0 2015-01-30 15:13:42.094
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
        /var/tmp/TALSTUD/configuration/org.eclipse.osgi/bundles/694/1/.cp/libswt-pi-gtk-3655.so: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
        no swt-pi-gtk in java.library.path
        /tmp/swtlib-64/libswt-pi-gtk-3655.so: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
        Can't load library: /tmp/swtlib-64/libswt-pi-gtk.so
        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:267)
        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:174)
        at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:22)
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
        at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
        at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:687)
        at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
        at org.talend.rcp.intro.Application.start(Application.java:85)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:606)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1383)
~
One Star

Re: Install of Talend Open Studio on Linux - Studio not Launching

I'm able to launch the TOS now, and currently installing the features.
I needed to install XMING and install the missing libraries. 
Moderator

Re: Install of Talend Open Studio on Linux - Studio not Launching

Hi,
Please take a look at documents about: TalendHelpCenter: Identify required external modules and TalendHelpCenter:Install external modules
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Install of Talend Open Studio on Linux - Studio not Launching

I am trying to install Talend Open Studio for Data Integration on CentOs 6.8.
I have followed all the steps. When I execute ./TOS_DI-linux-gtk-x86.sh, the window just does not respond.
It's displaying the following from a long time:
Setting property: classpath.resource.loader.class => 'org.codehaus.plexus.velocity.ContextClassLoaderResourceLoader'.
Setting property: velocimacro.messages.on => 'false'.
Setting property: resource.loader => 'classpath'.
Setting property: resource.manager.logwhenfound => 'false'.  
I am not able to figure out what should be done.
There is no GUI installed currently. I am accessing server through putty.
Thanks in advance.