I can't run Talend Open Studio Data Integration Linux

Four Stars

I can't run Talend Open Studio Data Integration Linux

I am trying to run TOS - Data Integration in Linux but it's not working.

 

!SESSION 2018-07-11 10:27:39.743 -----------------------------------------------
eclipse.buildId=unknown
java.version=10.0.1
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.talend.hadoop.distribution.cdh580 4 0 2018-07-11 10:27:42.049
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.hadoop.distribution.cdh580 [9]
Unresolved requirement: Require-Bundle: org.talend.core.runtime
-> Bundle-SymbolicName: org.talend.core.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.core.runtime [10]
Unresolved requirement: Require-Bundle: org.talend.model
-> Bundle-SymbolicName: org.talend.model; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.model [275]
Unresolved requirement: Require-Bundle: org.talend.commons.runtime
-> Bundle-SymbolicName: org.talend.commons.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.commons.runtime [450]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.core.runtime 4 0 2018-07-11 10:27:42.063
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.core.runtime [10]
Unresolved requirement: Require-Bundle: org.talend.model
-> Bundle-SymbolicName: org.talend.model; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.model [275]
Unresolved requirement: Require-Bundle: org.talend.commons.runtime
-> Bundle-SymbolicName: org.talend.commons.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.commons.runtime [450]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.designer.maven.ui 4 0 2018-07-11 10:27:42.072
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.designer.maven.ui [20]
Unresolved requirement: Require-Bundle: org.talend.model
-> Bundle-SymbolicName: org.talend.model; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.model [275]
Unresolved requirement: Require-Bundle: org.talend.commons.runtime
-> Bundle-SymbolicName: org.talend.commons.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.commons.runtime [450]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.hadoop.distribution.cdh4mr2 4 0 2018-07-11 10:27:42.075
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.hadoop.distribution.cdh4mr2 [23]
Unresolved requirement: Require-Bundle: org.talend.core.runtime
-> Bundle-SymbolicName: org.talend.core.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.core.runtime [10]
Unresolved requirement: Require-Bundle: org.talend.model
-> Bundle-SymbolicName: org.talend.model; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.model [275]
Unresolved requirement: Require-Bundle: org.talend.commons.runtime
-> Bundle-SymbolicName: org.talend.commons.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.commons.runtime [450]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.hadoop.distribution.hdinsight310 4 0 2018-07-11 10:27:42.078
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.hadoop.distribution.hdinsight310 [24]
Unresolved requirement: Require-Bundle: org.talend.core.runtime
-> Bundle-SymbolicName: org.talend.core.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.core.runtime [10]
Unresolved requirement: Require-Bundle: org.talend.model
-> Bundle-SymbolicName: org.talend.model; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.model [275]
Unresolved requirement: Require-Bundle: org.talend.commons.runtime
-> Bundle-SymbolicName: org.talend.commons.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.commons.runtime [450]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.components.jira 4 0 2018-07-11 10:27:42.083
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.components.jira [30]
Unresolved requirement: Import-Package: org.talend.components.api; version="[0.23.0,1.0.0)"
-> Export-Package: org.talend.components.api; bundle-symbolic-name="org.talend.components.api"; bundle-version="0.23.1"; version="0.23.1"; uses:="org.talend.components.api.wizard,org.talend.daikon,org.talend.daikon.definition,org.talend.daikon.i18n,org.talend.daikon.i18n.tag"
org.talend.components.api [236]
Unresolved requirement: Import-Package: org.talend.daikon; version="[0.23.0,1.0.0)"
-> Export-Package: org.talend.daikon; bundle-symbolic-name="org.talend.daikon"; bundle-version="0.23.0"; version="0.23.0"; uses:="org.talend.daikon.i18n,org.talend.daikon.i18n.tag"
org.talend.daikon [66]
Unresolved requirement: Import-Package: org.ops4j.pax.url.mvn.internal; resolution:="optional"
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
Unresolved requirement: Import-Package: com.fasterxml.jackson.databind; version="[2.9.0,3.0.0)"; resolution:="optional"
-> Export-Package: com.fasterxml.jackson.databind; bundle-symbolic-name="com.fasterxml.jackson.core.jackson-databind"; bundle-version="2.9.4"; version="2.9.4"; uses:="com.fasterxml.jackson.annotation,com.fasterxml.jackson.core,com.fasterxml.jackson.core.filter,com.fasterxml.jackson.core.format,com.fasterxml.jackson.core.io,com.fasterxml.jackson.core.type,com.fasterxml.jackson.databind.annotation,com.fasterxml.jackson.databind.cfg,com.fasterxml.jackson.databind.deser,com.fasterxml.jackson.databind.deser.impl,com.fasterxml.jackson.databind.introspect,com.fasterxml.jackson.databind.jsonFormatVisitors,com.fasterxml.jackson.databind.jsonschema,com.fasterxml.jackson.databind.jsontype,com.fasterxml.jackson.databind.jsontype.impl,com.fasterxml.jackson.databind.node,com.fasterxml.jackson.databind.ser,com.fasterxml.jackson.databind.ser.impl,com.fasterxml.jackson.databind.type,com.fasterxml.jackson.databind.util"
com.fasterxml.jackson.core.jackson-databind [60]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
Unresolved requirement: Import-Package: com.fasterxml.jackson.databind.node; version="[2.9.0,3.0.0)"; resolution:="optional"
-> Export-Package: com.fasterxml.jackson.databind.node; bundle-symbolic-name="com.fasterxml.jackson.core.jackson-databind"; bundle-version="2.9.4"; version="2.9.4"; uses:="com.fasterxml.jackson.core,com.fasterxml.jackson.core.base,com.fasterxml.jackson.databind,com.fasterxml.jackson.databind.jsontype,com.fasterxml.jackson.databind.util"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.help.googledrive 4 0 2018-07-11 10:27:42.088
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.help.googledrive [34]
Unresolved requirement: Require-Bundle: org.talend.commons.ui
-> Bundle-SymbolicName: org.talend.commons.ui; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.commons.ui [686]
Unresolved requirement: Require-Bundle: org.talend.utils
-> Bundle-SymbolicName: org.talend.utils; bundle-version="7.0.1.20180411_1414"
org.talend.utils [445]
Unresolved requirement: Require-Bundle: org.talend.daikon; visibility:="reexport"
-> Bundle-SymbolicName: org.talend.daikon; bundle-version="0.23.0"
org.talend.daikon [66]
Unresolved requirement: Import-Package: org.ops4j.pax.url.mvn.internal; resolution:="optional"
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
Unresolved requirement: Import-Package: com.fasterxml.jackson.databind; version="[2.9.0,3.0.0)"; resolution:="optional"
-> Export-Package: com.fasterxml.jackson.databind; bundle-symbolic-name="com.fasterxml.jackson.core.jackson-databind"; bundle-version="2.9.4"; version="2.9.4"; uses:="com.fasterxml.jackson.annotation,com.fasterxml.jackson.core,com.fasterxml.jackson.core.filter,com.fasterxml.jackson.core.format,com.fasterxml.jackson.core.io,com.fasterxml.jackson.core.type,com.fasterxml.jackson.databind.annotation,com.fasterxml.jackson.databind.cfg,com.fasterxml.jackson.databind.deser,com.fasterxml.jackson.databind.deser.impl,com.fasterxml.jackson.databind.introspect,com.fasterxml.jackson.databind.jsonFormatVisitors,com.fasterxml.jackson.databind.jsonschema,com.fasterxml.jackson.databind.jsontype,com.fasterxml.jackson.databind.jsontype.impl,com.fasterxml.jackson.databind.node,com.fasterxml.jackson.databind.ser,com.fasterxml.jackson.databind.ser.impl,com.fasterxml.jackson.databind.type,com.fasterxml.jackson.databind.util"
com.fasterxml.jackson.core.jackson-databind [60]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
Unresolved requirement: Import-Package: com.fasterxml.jackson.databind.node; version="[2.9.0,3.0.0)"; resolution:="optional"
-> Export-Package: com.fasterxml.jackson.databind.node; bundle-symbolic-name="com.fasterxml.jackson.core.jackson-databind"; bundle-version="2.9.4"; version="2.9.4"; uses:="com.fasterxml.jackson.core,com.fasterxml.jackson.core.base,com.fasterxml.jackson.databind,com.fasterxml.jackson.databind.jsontype,com.fasterxml.jackson.databind.util"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

 

...

 


Accepted Solutions
Moderator

Re: I can't run Talend Open Studio Data Integration Linux

Hello,

We are not targetting java 10 yet. Could you please use java 8 instead to see if it works?

Please have a look at this online document about:TalendHelpCenter:Compatible Java Environments.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

All Replies
Moderator

Re: I can't run Talend Open Studio Data Integration Linux

Hello,

We are not targetting java 10 yet. Could you please use java 8 instead to see if it works?

Please have a look at this online document about:TalendHelpCenter:Compatible Java Environments.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: I can't run Talend Open Studio Data Integration Linux

As you said, I have installed Java 8 but another error message pops out:

 

JVM terminated. Exit code=2
/home/ubuntu/Desktop/TOS_DI-20180411_1414-V7.0.1/jre/bin/java
-Xms512m
-Xmx1536m
-Dfile.encoding=UTF-8
-Dosgi.requiredJavaVersion=1.8
-XX:+UseG1GC
-XX:+UseStringDeduplication
-jar /home/ubuntu/Desktop/TOS_DI-20180411_1414-V7.0.1/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /home/ubuntu/Desktop/TOS_DI-20180411_1414-V7.0.1/TOS_DI-linux-gtk-x86_64
-name TOS_DI-linux-gtk-x86_64
--launcher.library /home/ubuntu/Desktop/TOS_DI-20180411_1414-V7.0.1/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140603-1326/eclipse_1605.so
-startup /home/ubuntu/Desktop/TOS_DI-20180411_1414-V7.0.1/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
--launcher.overrideVmargs
-exitdata f20038
-vm /home/ubuntu/Desktop/TOS_DI-20180411_1414-V7.0.1/jre/bin/java
-vmargs
-Xms512m
-Xmx1536m
-Dfile.encoding=UTF-8
-Dosgi.requiredJavaVersion=1.8
-XX:+UseG1GC
-XX:+UseStringDeduplication
-jar /home/ubuntu/Desktop/TOS_DI-20180411_1414-V7.0.1/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar

 

Thank you.

Moderator

Re: I can't run Talend Open Studio Data Integration Linux

Hello,

Is your java environment set correctly?

Ensure proper version of JDK is installed. For v6 of Talend products JDKv1.8 is required instead of JRE. If that requirement is met, ensure JDK bin is included in your PATH environment variable and is being reached.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.