One Star

General errors reading files on Vista: RESOLVED (sort of)

To anyone who's having issues on Vista, run as Administrator. Anyone have a better solution?
Having not used TOS for many months, I came back and installed on a Vista machine. Everything _appeared_ ok, but I couldn't read an Excel 2007 file. So I tried an Excel 97 format. Then I tried a csv and even single column text file: I think it's Vista's file permission restrictions.
Launching Talend Open Studio as administrator (In Vista, right-click the TOS icon, select Run As Administrator) launched and showed me what looked like a fresh repository and everything.. Ok, no big deal since my last ones didn't work Smiley Happy. I tried a simple file read, and it worked the first time.
Hope this helps!
oh, here is a sample, confusing error message I used to get when running on Vista but not as administrator:
Exception in thread "main" java.lang.NoClassDefFoundError: com/csvreader/CsvWriter
at remove_bounces_for_herrick.shadowfileinputtodelimitedoutput_0_1.ShadowFileInputToDelimitedOutput.tFileInputDelimitedProcess(ShadowFileInputToDelimitedOutput.java:364)
at remove_bounces_for_herrick.shadowfileinputtodelimitedoutput_0_1.ShadowFileInputToDelimitedOutput.runJobInTOS(ShadowFileInputToDelimitedOutput.java:859)
at remove_bounces_for_herrick.shadowfileinputtodelimitedoutput_0_1.ShadowFileInputToDelimitedOutput.main(ShadowFileInputToDelimitedOutput.java:759)
Caused by: java.lang.ClassNotFoundException: com.csvreader.CsvWriter
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 3 more
Preview error. Some settings must be changed.
Note: Preview errors are generally due to a wrong encoding setting.
org.talend.designer.runprocess.shadow.ShadowFilePreview.preview(Unknown Source)
org.talend.repository.ui.utils.ShadowProcessHelper.getCsvArray(Unknown Source)
org.talend.designer.filemultischemas.ui.preview.MultiSchemasUIThreadProcessor.nonUIProcessInThread(Unknown Source)
org.talend.commons.ui.swt.thread.SWTUIThreadProcessor$1.run(Unknown Source)

Another error I got was something like "Missing class error". Hope this helps.
2 REPLIES
Community Manager

Re: General errors reading files on Vista: RESOLVED (sort of)

Hello
Thanks for your solution!
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: General errors reading files on Vista: RESOLVED (sort of)

Hi Team,
I am getting the same error while running the job on TAC and the is job running fine in Studio.
Thanks in advance