Four Stars

Framework Error : Could not resolve module: org.eclipse.m2e.discovery [642] Unresolved requirement: Import-Package: org.eclipse.equinox.internal.p2.discovery.compatibility

Hi Team,

 

I am trying to open my talend 6.2.1 but getting below error.

 

To get it working i had removed \configuration\org.eclipse.osgi

also removed \configuration folder then tried

got a copy of configuration folder from working copy.

 but every time it showed same error: any help would be great to get it up and running

 

org.osgi.framework.BundleException: Could not resolve module: org.eclipse.m2e.discovery [642]
Unresolved requirement: Import-Package: org.eclipse.equinox.internal.p2.discovery.compatibility

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

2 REPLIES
Community Manager

Re: Framework Error : Could not resolve module: org.eclipse.m2e.discovery [642] Unresolved requirement: Import-Package: org.eclipse.equinox.internal.p2.discovery.compatibility

Hi
Can you upload the log file which is located in <talend studio install dir>/workspace/.metadata.
BTW, v6.2.1 is a very old version, I would suggest you to download and use the latest version 7.0.1 for more features and better performance.

Regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
Four Stars

Re: Framework Error : Could not resolve module: org.eclipse.m2e.discovery [642] Unresolved requirement: Import-Package: org.eclipse.equinox.internal.p2.discovery.compatibility

Hi Shong,

 

I have uploaded the log file.

 

Under current situation i can not take up latest version.

 

Thanks,

Amit