Five Stars

Export/Import items in version 6.4.0 doesn't work for older versions

Hi,

 

has anyone of you faced an issue in importing jobs with an older version of Talend from version 6.4?

I have doen this many times (export items) and import them, but there seems to be something not working when the versions come from 6.4.

Screen Shot 2017-05-29 at 5.19.59 PM.png

 

I just get this. Any clue? Anything you ve already faced?

  • Talend Data Preparation
1 ACCEPTED SOLUTION

Accepted Solutions
Employee

Re: Export/Import items in version 6.4.0 doesn't work for older versions

Generally, Talend only support exporting from older version and importing into same or newer versions of Talend. Exporting from Talend 6.4.0 and importing in in a 6.3.1 or earlier version is not supported.

The reason for this is because there is an automatic migration process in the studio which will migrate all your jobs to use the latest components. The newer version of Talend may have new metadata types, components may have additional options, etc. These are saved in the job. When you import this job in older version, the older version of the studio migration scripts don't know how to read those new options etc in your job.

By the way, 6.4.1 has just been released.
2 REPLIES
Nine Stars

Re: Export/Import items in version 6.4.0 doesn't work for older versions

6.4 have some more fundamental problems, for this reason I only test it and not replace 6.3.1 in production

 

but this part is work, and import and export. Tested many times

-----------
Employee

Re: Export/Import items in version 6.4.0 doesn't work for older versions

Generally, Talend only support exporting from older version and importing into same or newer versions of Talend. Exporting from Talend 6.4.0 and importing in in a 6.3.1 or earlier version is not supported.

The reason for this is because there is an automatic migration process in the studio which will migrate all your jobs to use the latest components. The newer version of Talend may have new metadata types, components may have additional options, etc. These are saved in the job. When you import this job in older version, the older version of the studio migration scripts don't know how to read those new options etc in your job.

By the way, 6.4.1 has just been released.