One Star

Error launching Talend Studio for DQ - Could not resolve modules

Running on Windows 10 with Java 9.0.4 and I've followed all the installation and system config instructions in the Installation Guide.

Here is a sample from the error log file (complete log file is attached):

 

 

!SESSION 2018-05-15 10:17:13.529 -----------------------------------------------
eclipse.buildId=unknown
java.version=9.0.4
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.jdt.launching.macosx 4 0 2018-05-15 10:17:15.165
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.macosx [227]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.jdt.launching.ui.macosx 4 0 2018-05-15 10:17:15.173
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.ui.macosx [229]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.common.ui.runtime 4 0 2018-05-15 10:17:15.194
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.common.ui.runtime [361]
  Unresolved requirement: Import-Package: org.eclipse.swt
    -> Export-Package: org.eclipse.swt; bundle-symbolic-name="org.eclipse.swt.cocoa.macosx"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.cocoa.macosx [286]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) )"
  Unresolved requirement: Require-Bundle: org.talend.commons.runtime
    -> Bundle-SymbolicName: org.talend.commons.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
       org.talend.commons.runtime [363]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
  Unresolved requirement: Import-Package: org.eclipse.swt.custom
    -> Export-Package: org.eclipse.swt.custom; bundle-symbolic-name="org.eclipse.swt.gtk.linux.s390"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.gtk.linux.s390 [302]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=s390))"
  Unresolved requirement: Import-Package: org.eclipse.swt.layout
    -> Export-Package: org.eclipse.swt.layout; bundle-symbolic-name="org.eclipse.swt.gtk.linux.x86"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.gtk.linux.x86 [304]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))"
  Unresolved requirement: Import-Package: org.eclipse.swt.events
    -> Export-Package: org.eclipse.swt.events; bundle-symbolic-name="org.eclipse.swt.gtk.linux.ppc64le"; bundle-version="3.103.1.v20140903-1936"; version="0.0.0"
       org.eclipse.swt.gtk.linux.ppc64le [296]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64le))"
  Unresolved requirement: Import-Package: org.eclipse.swt.graphics
    -> Export-Package: org.eclipse.swt.graphics; bundle-symbolic-name="org.eclipse.swt.gtk.solaris.sparc"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.gtk.solaris.sparc [308]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=solaris) (osgi.arch=sparc))"
  Unresolved requirement: Import-Package: org.eclipse.swt.widgets
    -> Export-Package: org.eclipse.swt.widgets; bundle-symbolic-name="org.eclipse.swt.gtk.aix.ppc64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
       org.eclipse.swt.gtk.aix.ppc64 [289]
         Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=aix) (osgi.arch=ppc64))"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.commons.runtime 4 0 2018-05-15 10:17:15.200
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.commons.runtime [363]
  Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

 

1 ACCEPTED SOLUTION

Accepted Solutions
One Star

Re: Error launching Talend Studio for DQ - Could not resolve modules

Resolved:  I just had to install JDK 8

2 REPLIES
One Star

Re: Error launching Talend Studio for DQ - Could not resolve modules

Resolved:  I just had to install JDK 8

Moderator

Re: Error launching Talend Studio for DQ - Could not resolve modules

Hello,

Great your issue has been resolved.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.