Four Stars

Error Exec Talend "org.osgi.framework.BundleException"

Hello,

 

I get an error today when i tried to open talend :

 

 

!SESSION 2017-12-04 11:00:04.312 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_151
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Command-line arguments:  -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.jdt.launching.macosx 4 0 2017-12-04 11:00:05.718
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.macosx [335]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

    at org.eclipse.osgi.container.Module.start(Module.java:434)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

 

U can find all log attached

I did a research in internet, and i tried many solution but i didn't found a solution.

 

 

Can you help please.

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Four Stars

Re: Error Exec Talend "org.osgi.framework.BundleException"

Hello,

 

Thanks for your reply, the solution is to delete the folder

"<studio>\configuration\org.eclipse.osgi"

 

Thanks.

2 REPLIES
Moderator

Re: Error Exec Talend "org.osgi.framework.BundleException"

Hello,

Ensure proper version of JDK is installed. For v6 of Talend products JDKv1.8 is required instead of JRE.

What is your JDK Compliance level in Studio Java Compiler preferences?  Is it set to 1.7 or 1.8?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Error Exec Talend "org.osgi.framework.BundleException"

Hello,

 

Thanks for your reply, the solution is to delete the folder

"<studio>\configuration\org.eclipse.osgi"

 

Thanks.