[ESB] tesb:start-all fail

Highlighted
Four Stars

[ESB] tesb:start-all fail

Hi,

 

I'm trying to install all the ESB parts on a server on Windows 2016 Server, and Talend 6.2

When i try to launch the command tesb:start-all on karaf i have this :


Error executing command: Error restarting bundles

 

If i go to log i have this error

 

 

org.apache.karaf.features.internal.util.MultiException: Error restarting bundles
	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:854)[9:org.apache.karaf.features.core:4.0.5]
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1152)[9:org.apache.karaf.features.core:4.0.5]
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:1048)[9:org.apache.karaf.features.core:4.0.5]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_191]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)[:1.8.0_191]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)[:1.8.0_191]
	at java.lang.Thread.run(Thread.java:748)[:1.8.0_191]
Caused by: org.osgi.framework.BundleException: Could not resolve module: org.hyperic.sigar [233]
  Unresolved requirement: Import-Package: junit.framework; resolution:="optional"
  Unresolved requirement: Import-Package: junit.textui; resolution:="optional"
  Unresolved requirement: Require-Capability: osgi.native; native.paths.8:List<String>="lib/sigar-x86-winnt.dll"; native.paths.7:List<String>="lib/libsigar-amd64-solaris.so"; native.paths.9:List<String>="lib/sigar-amd64-winnt.dll"; native.paths.11:List<String>="lib/libsigar-ppc64-aix-5.so"; native.paths.10:List<String>="lib/libsigar-ppc-aix-5.so"; native.paths.0:List<String>="lib/libsigar-universal64-macosx.jnilib"; native.paths.2:List<String>="lib/libsigar-x86-linux.so"; native.paths.1:List<String>="lib/libsigar-universal-macosx.jnilib"; native.paths.4:List<String>="lib/libsigar-sparc-solaris.so"; native.paths.3:List<String>="lib/libsigar-amd64-linux.so"; native.paths.6:List<String>="lib/libsigar-x86-solaris.so"; native.paths.5:List<String>="lib/libsigar-sparc64-solaris.so"; filter:="(|(&(osgi.native.osname~=MacOSX)(|(osgi.native.processor~=x86_64)(osgi.native.processor~=x86-64)(osgi.native.processor~=amd64)))(&(osgi.native.osname~=MacOSX)(osgi.native.processor~=x86))(&(osgi.native.osname~=Linux)(osgi.native.processor~=x86))(&(osgi.native.osname~=Linux)(|(osgi.native.processor~=x86_64)(osgi.native.processor~=x86-64)(osgi.native.processor~=amd64)))(&(osgi.native.osname~=SunOS)(osgi.native.processor~=Sparc))(&(osgi.native.osname~=SunOS)(osgi.native.processor~=Sparcv9))(&(osgi.native.osname~=SunOS)(osgi.native.processor~=x86))(&(osgi.native.osname~=SunOS)(|(osgi.native.processor~=amd64)(osgi.native.processor~=x86_64)(osgi.native.processor~=x86-64)))(&(|(osgi.native.osname~=win32)(osgi.native.osname~=WindowsNT)(osgi.native.osname~=Windows2000)(osgi.native.osname~=Win2000)(osgi.native.osname~=WindowsXP)(osgi.native.osname~=Windows2003)(osgi.native.osname~=WindowsVista)(osgi.native.osname~=Windows7)(osgi.native.osname~=windows server 2008)(osgi.native.osname~=windows server 2008 r2)(osgi.native.osname~=windows server 2012)(osgi.native.osname~=Windows Server 2012 R2)(osgi.native.osname~=Windows 8)(osgi.native.osname~=Windows 8.1)(osgi.native.osname~=Windows 10))(osgi.native.processor~=x86))(&(|(osgi.native.osname~=win32)(osgi.native.osname~=WindowsNT)(osgi.native.osname~=Windows2000)(osgi.native.osname~=Win2000)(osgi.native.osname~=WindowsXP)(osgi.native.osname~=Windows2003)(osgi.native.osname~=WindowsVista)(osgi.native.osname~=Windows7)(osgi.native.osname~=windows server 2008)(osgi.native.osname~=windows server 2008 r2)(osgi.native.osname~=windows server 2012)(osgi.native.osname~=Windows Server 2012 R2)(osgi.native.osname~=Windows 8)(osgi.native.osname~=Windows 8.1)(osgi.native.osname~=Windows 10))(|(osgi.native.processor~=x86-64)(osgi.native.processor~=x86_64)(osgi.native.processor~=amd64)))(&(osgi.native.osname~=AIX)(osgi.native.processor~=ppc))(&(osgi.native.osname~=AIX)(osgi.native.processor~=ppc64)))"

	at org.eclipse.osgi.container.Module.start(Module.java:434)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:393)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:412)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:1262)[9:org.apache.karaf.features.core:4.0.5]
	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:846)[9:org.apache.karaf.features.core:4.0.5]
	... 6 more
Caused by: org.osgi.framework.BundleException: Could not resolve module: org.talend.monitoring.server [256]
  Unresolved requirement: Import-Package: org.hyperic.sigar
    -> Export-Package: org.hyperic.sigar; bundle-symbolic-name="org.hyperic.sigar"; bundle-version="1.6.4"; version="1.6.4"; uses:="org.apache.log4j"
       org.hyperic.sigar [233]
         Unresolved requirement: Import-Package: junit.framework; resolution:="optional"
         Unresolved requirement: Import-Package: junit.textui; resolution:="optional"
         Unresolved requirement: Require-Capability: osgi.native; native.paths.8:List<String>="lib/sigar-x86-winnt.dll"; native.paths.7:List<String>="lib/libsigar-amd64-solaris.so"; native.paths.9:List<String>="lib/sigar-amd64-winnt.dll"; native.paths.11:List<String>="lib/libsigar-ppc64-aix-5.so"; native.paths.10:List<String>="lib/libsigar-ppc-aix-5.so"; native.paths.0:List<String>="lib/libsigar-universal64-macosx.jnilib"; native.paths.2:List<String>="lib/libsigar-x86-linux.so"; native.paths.1:List<String>="lib/libsigar-universal-macosx.jnilib"; native.paths.4:List<String>="lib/libsigar-sparc-solaris.so"; native.paths.3:List<String>="lib/libsigar-amd64-linux.so"; native.paths.6:List<String>="lib/libsigar-x86-solaris.so"; native.paths.5:List<String>="lib/libsigar-sparc64-solaris.so"; filter:="(|(&(osgi.native.osname~=MacOSX)(|(osgi.native.processor~=x86_64)(osgi.native.processor~=x86-64)(osgi.native.processor~=amd64)))(&(osgi.native.osname~=MacOSX)(osgi.native.processor~=x86))(&(osgi.native.osname~=Linux)(osgi.native.processor~=x86))(&(osgi.native.osname~=Linux)(|(osgi.native.processor~=x86_64)(osgi.native.processor~=x86-64)(osgi.native.processor~=amd64)))(&(osgi.native.osname~=SunOS)(osgi.native.processor~=Sparc))(&(osgi.native.osname~=SunOS)(osgi.native.processor~=Sparcv9))(&(osgi.native.osname~=SunOS)(osgi.native.processor~=x86))(&(osgi.native.osname~=SunOS)(|(osgi.native.processor~=amd64)(osgi.native.processor~=x86_64)(osgi.native.processor~=x86-64)))(&(|(osgi.native.osname~=win32)(osgi.native.osname~=WindowsNT)(osgi.native.osname~=Windows2000)(osgi.native.osname~=Win2000)(osgi.native.osname~=WindowsXP)(osgi.native.osname~=Windows2003)(osgi.native.osname~=WindowsVista)(osgi.native.osname~=Windows7)(osgi.native.osname~=windows server 2008)(osgi.native.osname~=windows server 2008 r2)(osgi.native.osname~=windows server 2012)(osgi.native.osname~=Windows Server 2012 R2)(osgi.native.osname~=Windows 8)(osgi.native.osname~=Windows 8.1)(osgi.native.osname~=Windows 10))(osgi.native.processor~=x86))(&(|(osgi.native.osname~=win32)(osgi.native.osname~=WindowsNT)(osgi.native.osname~=Windows2000)(osgi.native.osname~=Win2000)(osgi.native.osname~=WindowsXP)(osgi.native.osname~=Windows2003)(osgi.native.osname~=WindowsVista)(osgi.native.osname~=Windows7)(osgi.native.osname~=windows server 2008)(osgi.native.osname~=windows server 2008 r2)(osgi.native.osname~=windows server 2012)(osgi.native.osname~=Windows Server 2012 R2)(osgi.native.osname~=Windows 8)(osgi.native.osname~=Windows 8.1)(osgi.native.osname~=Windows 10))(|(osgi.native.processor~=x86-64)(osgi.native.processor~=x86_64)(osgi.native.processor~=amd64)))(&(osgi.native.osname~=AIX)(osgi.native.processor~=ppc))(&(osgi.native.osname~=AIX)(osgi.native.processor~=ppc64)))"

	at org.eclipse.osgi.container.Module.start(Module.java:434)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:393)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:412)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:1262)[9:org.apache.karaf.features.core:4.0.5]
	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:846)[9:org.apache.karaf.features.core:4.0.5]
	... 6 more
Caused by: org.osgi.framework.BundleException: Could not resolve module: org.talend.remote.jobserver.server [259]
  Unresolved requirement: Import-Package: org.talend.monitoring.jmx.server; version="[6.2.0,7.0.0)"
    -> Export-Package: org.talend.monitoring.jmx.server; bundle-symbolic-name="org.talend.monitoring.server"; bundle-version="6.2.1"; version="6.2.1"; uses:="javax.management,javax.management.remote,org.talend.monitoring.jmx.api"
       org.talend.monitoring.server [256]
         Unresolved requirement: Import-Package: org.hyperic.sigar
           -> Export-Package: org.hyperic.sigar; bundle-symbolic-name="org.hyperic.sigar"; bundle-version="1.6.4"; version="1.6.4"; uses:="org.apache.log4j"
              org.hyperic.sigar [233]
                Unresolved requirement: Import-Package: junit.framework; resolution:="optional"
                Unresolved requirement: Import-Package: junit.textui; resolution:="optional"
                Unresolved requirement: Require-Capability: osgi.native; native.paths.8:List<String>="lib/sigar-x86-winnt.dll"; native.paths.7:List<String>="lib/libsigar-amd64-solaris.so"; native.paths.9:List<String>="lib/sigar-amd64-winnt.dll"; native.paths.11:List<String>="lib/libsigar-ppc64-aix-5.so"; native.paths.10:List<String>="lib/libsigar-ppc-aix-5.so"; native.paths.0:List<String>="lib/libsigar-universal64-macosx.jnilib"; native.paths.2:List<String>="lib/libsigar-x86-linux.so"; native.paths.1:List<String>="lib/libsigar-universal-macosx.jnilib"; native.paths.4:List<String>="lib/libsigar-sparc-solaris.so"; native.paths.3:List<String>="lib/libsigar-amd64-linux.so"; native.paths.6:List<String>="lib/libsigar-x86-solaris.so"; native.paths.5:List<String>="lib/libsigar-sparc64-solaris.so"; filter:="(|(&(osgi.native.osname~=MacOSX)(|(osgi.native.processor~=x86_64)(osgi.native.processor~=x86-64)(osgi.native.processor~=amd64)))(&(osgi.native.osname~=MacOSX)(osgi.native.processor~=x86))(&(osgi.native.osname~=Linux)(osgi.native.processor~=x86))(&(osgi.native.osname~=Linux)(|(osgi.native.processor~=x86_64)(osgi.native.processor~=x86-64)(osgi.native.processor~=amd64)))(&(osgi.native.osname~=SunOS)(osgi.native.processor~=Sparc))(&(osgi.native.osname~=SunOS)(osgi.native.processor~=Sparcv9))(&(osgi.native.osname~=SunOS)(osgi.native.processor~=x86))(&(osgi.native.osname~=SunOS)(|(osgi.native.processor~=amd64)(osgi.native.processor~=x86_64)(osgi.native.processor~=x86-64)))(&(|(osgi.native.osname~=win32)(osgi.native.osname~=WindowsNT)(osgi.native.osname~=Windows2000)(osgi.native.osname~=Win2000)(osgi.native.osname~=WindowsXP)(osgi.native.osname~=Windows2003)(osgi.native.osname~=WindowsVista)(osgi.native.osname~=Windows7)(osgi.native.osname~=windows server 2008)(osgi.native.osname~=windows server 2008 r2)(osgi.native.osname~=windows server 2012)(osgi.native.osname~=Windows Server 2012 R2)(osgi.native.osname~=Windows 8)(osgi.native.osname~=Windows 8.1)(osgi.native.osname~=Windows 10))(osgi.native.processor~=x86))(&(|(osgi.native.osname~=win32)(osgi.native.osname~=WindowsNT)(osgi.native.osname~=Windows2000)(osgi.native.osname~=Win2000)(osgi.native.osname~=WindowsXP)(osgi.native.osname~=Windows2003)(osgi.native.osname~=WindowsVista)(osgi.native.osname~=Windows7)(osgi.native.osname~=windows server 2008)(osgi.native.osname~=windows server 2008 r2)(osgi.native.osname~=windows server 2012)(osgi.native.osname~=Windows Server 2012 R2)(osgi.native.osname~=Windows 8)(osgi.native.osname~=Windows 8.1)(osgi.native.osname~=Windows 10))(|(osgi.native.processor~=x86-64)(osgi.native.processor~=x86_64)(osgi.native.processor~=amd64)))(&(osgi.native.osname~=AIX)(osgi.native.processor~=ppc))(&(osgi.native.osname~=AIX)(osgi.native.processor~=ppc64)))"

	at org.eclipse.osgi.container.Module.start(Module.java:434)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:393)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:412)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:1262)[9:org.apache.karaf.features.core:4.0.5]
	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:846)[9:org.apache.karaf.features.core:4.0.5]

Do you have an idea of this issue ?

 

Regards

 


Accepted Solutions
Moderator

Re: [ESB] tesb:start-all fail

Hello,

 This seems to be the problem specific to the Windows 2016 operating system. 

Could you please shutdown the runtime services,  open Start.bat file in the Runtime Installation Directory, add the JVM argument -Dorg.osgi.framework.os.name =32 and restart the runtime services to see if it works?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

All Replies
Moderator

Re: [ESB] tesb:start-all fail

Hello,

 This seems to be the problem specific to the Windows 2016 operating system. 

Could you please shutdown the runtime services,  open Start.bat file in the Runtime Installation Directory, add the JVM argument -Dorg.osgi.framework.os.name =32 and restart the runtime services to see if it works?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Moderator

Re: [ESB] tesb:start-all fail

Hello,

 This seems to be the problem specific to the Windows 2016 operating system. 

Could you please shutdown the runtime services,  open Start.bat file in the Runtime Installation Directory, add the JVM argument -Dorg.osgi.framework.os.name =32 and restart the runtime services to see if it works?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: [ESB] tesb:start-all fail

Hello,

Yes it works, thank you Sabrina

Regards
Yoann
Moderator

Re: [ESB] tesb:start-all fail

Hello,

Great it works. Thanks for your quick feedback and feel free to post your issue here.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

An API-First Approach to Modernizing Applications

Learn how to use an API-First Approach to Modernize your Applications

Watch Now

Talend API Designer – Technical Overview

Take a look at this technical overview video of Talend API Designer

Watch Now

Getting Started with APIs

Find out how to get started with APIs

Read