Four Stars

DB connection failure for DB configuration in TAC

Hi Team,

 

I have installed Talend latest version. when i'm configuring the TAC. its sending me error for DB connection.

 

I have cleared the temp and work folder in tomcat-apache folder it got worked for the first time and then after sometime its getting disconnecting.

 

Regards,

Rajesh REddy

 

 

 

 

4 REPLIES
Employee

Re: DB connection failure for DB configuration in TAC

Try changing the URL field with the IP address of your MySQL server instead of using localhost.

In addition, try configuring the TAC db connection to indicate to MySQL server  that 
it is a non SSL connection to be established between the TAC and MySQL server.
To implement this solution, the "useSSL" property set to "false"  is passed via MySQL JDBC connect string.


Against this specific issue, just replace the TAC Database parameter Url value 
jdbc:mysql://127.0.0.1:3306/talend_administrator
by this value : 
jdbc:mysql://127.0.0.1:3306/talend_administrator?useSSL=false


Please don't forget to kudo and accept as resolution if this resolves the issue.

Please don't forget to kudo and accept as resolution if this resolves the issue.
Four Stars

Re: DB connection failure for DB configuration in TAC

@jhackworth: Thank you for the reply, I have tried replacing the localhost with IP address but its still the same. i'm facing the below error

 

ERROR: Cannot connect to database (Communications link failure The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.)

 

Moderator

Re: DB connection failure for DB configuration in TAC

Hello,

Have you tried to modify 'wait_timeout' in your MySql DB to see if it works?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Six Stars

Re: DB connection failure for DB configuration in TAC

Hello Rajesh Reddy,

 

have you tried to place the mysql-connector-java.jar file in "<Tomcat_Directory>\webapps\org.talend.administrator\WEB-INF\lib"?

 

Best regards,

 

Thomas