One Star

Compiling with Java 1.7.

Hello,
I'd like to compile my jobs with a later version of Java, I understand that 1.8 isn't supported so I've been trying with 1.7. I can get Talend to start using this as it's JVM but in preferences > Java > compiler I can only downgrade. Is it possible to compile jobs using a later version than 1.6?
Thanks!
3 REPLIES
One Star

Re: Compiling with Java 1.7.

I'm on Talend Open Studio (DI) 5.6.1 and seeing this same issue.
I don't understand - the supported platforms notes include Java 1.7, but it seems that Talend can't actually compile using the 1.7 JDK? 
Even Java version 1.7 isn't having any new patches after April, so to only be able to compile to 1.6 and previous seems odd - maybe we're misunderstanding something?
Moderator

Re: Compiling with Java 1.7.

Hi,
Did you get any compile error with JDK 1.7 in Talend Studio?
So far, 1.7 jdk compiler is not available from drop down in Talend Studio.
Please vote for a new feature jira issue:https://jira.talendforge.org/browse/TDI-21706
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Compiling with Java 1.7.

Thanks very much for the response.
Please can you tell me how I can compile with JDK 1.7, given that it's not available from the dropdown?