One Star

Compiling source code of Talend Open studio for data integration 5.5.1

Hello Everyone,
I have checked out the Talend version 5.5.1 data integration source code from the following links
1) Git :
a) github.com/Talend/tdi-studio-se.git
b) github.com/Talend/tcommon-studio-se.git
2) SVN : svn.talendforge.org/svn/tos
I want to compile the source code and build the jars for all the modules of Talend Open Studio.
Please let me know what is the eclipse and its plugins versions in order to compile the Talend source code for data integration version 5.5.1. Also it would be great if someone could point me to the step by step instructions on how to build the jars for the Talend Open Studio.
20 REPLIES
Moderator

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Hi,
Please see a related forum http://www.talendforge.org/forum/viewtopic.php?id=12873.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Hello Sabrina,
I went through the forum mentioned by you:
www.talendforge.org/forum/viewtopic.php?id=12873.
But the eclipse version and the plugins mentioned on this forum are very old and it does not apply to newly released version i.e. Talend Open Studio data integration version 5.5.1.
The old eclipse versions and their plugins do not work with the latest source code and I have compilation errors from them.
Hence I would be grateful if someone gives me compatible version numbers for eclipse and its plugins which works with 5.5.1 release code.
Regards,
Mohasin.
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Sabrina?
what about the eclipse and plugins version  needed for tos 5.5.1 as #3 post?
thanks a lot!
Moderator

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Hi,
It should be Ok with Eclipse 4.X. Have you tried to use Eclipse 4 to compile source code to see if there is any errror?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Hi,
It should be Ok with Eclipse 4.X. Have you tried to use Eclipse 4 to compile source code to see if there is any errror?
Best regards
Sabrina

I have tried in eclipse 4.3 and 4.5.1 with plugins suggested in (http://talendforge.org/wiki/doku.php?id=dev:run_from_svn):
ATL SDK - ATLAS Transformation Language SDK
Ecore Tools SDK
M2T JET SDK 1.1.1

And all source code were checkout from svn, but it doesn't work with same error:
eclipse product invocation causes java.lang.RuntimeException: No application id has been found

And I have installed JDR 1.7 & 1.8 in standalone environment for eclipse 4.3 & 4.5.1, but there is no any change.
Am I missing something?
Thank you!
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

@talenditnow --   Out of curiosity, why are you interested in compiling TOS 5.5.1 instead of the latest version, 6.1.1?
@xdshi / Sabrina - I am personally interested in compiling the latest version, which is presently 6.1.1.  Are the instructions still the same for it?   Or, alternatively, I would be happy to just get the XSD for the .item file's XML of type "MapperData", if that's something that is easily available.  Of course I could generate the XSD from the TOS code, but I don't want to have to do that unless that's the only way to do it.  Thanks!
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

@talenditnow --   Out of curiosity, why are you interested in compiling TOS 5.5.1 instead of the latest version, 6.1.1?
@xdshi / Sabrina - I am personally interested in compiling the latest version, which is presently 6.1.1.  Are the instructions still the same for it?   Or, alternatively, I would be happy to just get the XSD for the .item file's XML of type "MapperData", if that's something that is easily available.  Of course I could generate the XSD from the TOS code, but I don't want to have to do that unless that's the only way to do it.  Thanks!

Actually, TOS 5.2.x, 5.5.x and all other version except 5.0.1 could not be compiled successfully, but version 5.0.1 was so outdated.
So TOS 5.5.x or new version such as 6.x was need, and the environment document was not updated.
Moderator

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Hi,
Sorry for delay!
Do you mean you have installed JDK 1.7 or JDK 1.8 successfully in your environment?
If you have more than one JDK installation on your machine, make sure the path to the most recent JDK version is set in the PATH system variable, before other versions.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Hi,
Sorry for delay!
Do you mean you have installed JDK 1.7 or JDK 1.8 successfully in your environment?
If you have more than one JDK installation on your machine, make sure the path to the most recent JDK version is set in the PATH system variable, before other versions.
Best regards
Sabrina

Darling, my heart was almost broken...
I have try JDK 1.7 with eclipse for java ee 4.3.2  in a standalone virtual machines of Ubuntu 12.04 LTS;
I have try JDK 1.8 with eclipse for java ee 4.3.2  in a standalone virtual machines of Ubuntu 12.04 LTS;
I have try JDK 1.7 with eclipse for java ee 4.5.1  in a standalone virtual machines of Ubuntu 12.04 LTS;
I have try JDK 1.8 with eclipse for java ee 4.5.1  in a standalone virtual machines of Ubuntu 12.04 LTS.
In all of these test environment, plugins introduced in
http://talendforge.org/wiki/doku.php?id=dev:run_from_svn&_ga=1.106575429.755324780.1455596377
was installed.
But, none of the TOS version after 5.0.1 could be compiled succefully.
What the whole environment for compiling 5.5 about eclipse version and plugins and jdk version does it need?
Moderator

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Hi,
Sorry for the inconvenience.
This guide is very old and we don't update it yet. This wiki guide is outdated.
We will make an investigation on your issue then come back to you as soon as we can.

Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Dear xdshi, have you update the document of compilation environment for new version of TOS?
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Hello,
Currently I´m struggling with the same issue of not being able to succesfully compiling the source code. Is there any progress on this matter here?
I've also created a new topic on the subject:
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Any idea?
Moderator

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Hi,
Did you get this issue when compile source code of Talend Open Studio for data integration 5.5.1 or 6.X?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Hi,
Did you get this issue when compile source code of Talend Open Studio for data integration 5.5.1 or 6.X?
Best regards
Sabrina

Yes, all version except 5.01 get the same error as post 6#.
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

hi xdshi
didn't you compile source code of Talend Open Studio for data integration 5.5.1 or 6.X sucess ?
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

hi talenditnow
didn't you compile source code of Talend Open Studio for data integration 5.5.1 or 6.X success ?
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

up up up
One Star

Re: Compiling source code of Talend Open studio for data integration 5.5.1

xdshi, what the correct procedure?
Moderator

Re: Compiling source code of Talend Open studio for data integration 5.5.1

Hi,
Sorry for delay.
We did compile source code of talend open studio for data integration 6.2(JDK 1.8). It works on our side.
Here is online document about:TalendHelpCenter:build-the-open-source-studio
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.