Four Stars

Can't launch the client after installing Talend ESB

Hi all,

First post !

I'm trying to install Talend ESB (Runtime) and i'm stuck right from the start. I can't launch the client.

I'm running on Ubuntu : 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux and jre  1.8.0_151-b12

I tried with the following version TOS_ESB-20171219_1109-V7.0.1M2.zip and TOS_ESB-20180116_1512-V6.5.1.zip, same issue.

Stat the runtime :

paracyber@inf70:/opt/Runtime_ESBSE/container/bin$ rm -rf ../log/tesb.log 
paracyber@inf70:/opt/Runtime_ESBSE/container/bin$ pwd
/opt/Runtime_ESBSE/container/bin
paracyber@inf70:/opt/Runtime_ESBSE/container/bin$ ./start
paracyber@inf70:/opt/Runtime_ESBSE/container/bin$ ps aux | grep java | grep ESB
1000     28122  115  1.4 5371540 178036 pts/8  Sl   09:42   0:10 /opt/java/jdk1.8.0_151/bin/java -server -Xms256M -Xmx1024M -XX:+UnlockDiagnosticVMOptions -XX:+UnsyncloadClass -Dcom.sun.management.jmxremote -Djava.endorsed.dirs=/opt/java/jdk1.8.0_151/jre/lib/endorsed:/opt/java/jdk1.8.0_151/lib/endorsed:/opt/Runtime_ESBSE/container/lib/endorsed -Djava.ext.dirs=/opt/java/jdk1.8.0_151/jre/lib/ext:/opt/java/jdk1.8.0_151/lib/ext:/opt/Runtime_ESBSE/container/lib/ext -Dkaraf.instances=/opt/Runtime_ESBSE/container/instances -Dkaraf.home=/opt/Runtime_ESBSE/container -Dkaraf.base=/opt/Runtime_ESBSE/container -Dkaraf.data=/opt/Runtime_ESBSE/container/data -Dkaraf.etc=/opt/Runtime_ESBSE/container/etc -Djava.io.tmpdir=/opt/Runtime_ESBSE/container/data/tmp -Djava.util.logging.config.file=/opt/Runtime_ESBSE/container/etc/java.util.logging.properties -Dkaraf.startLocalConsole=false -Dkaraf.startRemoteShell=true -classpath /opt/Runtime_ESBSE/container/lib/boot/jna-4.4.0.jar:/opt/Runtime_ESBSE/container/lib/boot/jna-platform-4.4.0.jar:/opt/Runtime_ESBSE/container/lib/boot/org.apache.karaf.diagnostic.boot-4.1.3.jar:/opt/Runtime_ESBSE/container/lib/boot/org.apache.karaf.jaas.boot-4.1.3.jar:/opt/Runtime_ESBSE/container/lib/boot/org.apache.karaf.main-4.1.3.jar:/opt/Runtime_ESBSE/container/lib/boot/org.osgi.core-6.0.0.jar org.apache.karaf.main.Main

The process seems to be listening

paracyber@inf70:/opt/Runtime_ESBSE/container/data$ netstat -atunp | grep java
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
tcp6       0      0 127.0.0.1:50370         :::*                    LISTEN      28122/java      
tcp6       0      0 :::48901                :::*                    LISTEN      28122/java      
paracyber@inf70:/opt/Runtime_ESBSE/container/data$ cat port 
50370

But when i run the client, i have the following error :

paracyber@inf70:/opt/Runtime_ESBSE/container/bin$ ./client 
Logging in as tadmin
Failed to get the session.

As an attachment, the log files. I have some erreurs related to components to search on internet. Is that the problem ?

I am behing a proxy, so no direct connection. Is this mandatory ? If wo, where to configure the proxy for runtime and its authentication ?

Regards,

 

David

1 REPLY
Moderator

Re: Can't launch the client after installing Talend ESB

Hello,

Could you please have a look at this online Installation and Upgrade Guide for Linux about TalendHelpCenter:Compatible Operating Systems

to see if you are on a compatible platform?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.