One Star

Can't compile Talend DI 6.2.1 job with jdk 1.6

Hi,
I'm trying to compile a job in Talend DI using jdk 1.6.
I have already configured the workspace in both : Windows->Preferences->Talend  and Windows->Preferences->java compiler.
But i'm getting this error message when running my job :
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/talend/designer/components/lookup/common/ICommonLookup$MATCHING_MODE : Unsupported major.minor version 51.0

It seems as though the libraries talend is using were not compiled using the jdk 1.6 ? :-/
I'm using Talend DI 6.2.1 on Windows 7 using jdk1.6.0_45
1 REPLY
Moderator

Re: Can't compile Talend DI 6.2.1 job with jdk 1.6

Hi,
Have you already checked document about:https://help.talend.com/search/all?query=Java&content-lang=en?
The recommended java environment is Oralce java 8 for V 6.2.1
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.