One Star

Can't build a job

Hi
I am using Talend Open Studio 6.3.0. (64 bit) on Windows 10 (64 bit).
When I try to build a job, Talend shows that it is working over something but after it is done, there is no zip file in target folder.
Talend functions properly when I just start jobs from Talend Studio but I want build jobs.
Some information about my PC:
C:\>java -version
java version "1.8.0_112"
Java(TM) SE Runtime Environment (build 1.8.0_112-b15)
Java HotSpot(TM) 64-Bit Server VM (build 25.112-b15, mixed mode)

Enviroment variables:
C:\>echo %JAVA_HOME%
C:\Program Files\Java\jdk1.8.0_112
C:\>echo %PATH%
C:\Program Files\Java\jdk1.8.0_112\bin;C:\ProgramData\Oracle\Java\jav;.........

In Talend:
Preferences > Java > Installed JREs: 

JRE name: jdk1.8.0_112
JRE home: C:\Program Files\Java\jdk1.8.0_112
Preferences > Talend

Java interpreter: C:\Program Files\Java\jdk1.8.0_112\bin\java.exe

There is no proxy in my network.
I start Talend with C:\Distr\Talend\Talend Open Studio V6.3.0\TOS_DI-win-x86_64.exe
There isn't any files with suffixes "*.lastUpdated" in C:\Distr\Talend\Talend Open Studio V6.3.0\configuration\.m2\repository\org\apache\maven\plugins\maven-resources-plugin\2.7
I've already tried to delete everything from C:\Distr\Talend\Talend Open Studio V6.3.0\configuration\.m2\repository but it did not help.
I tried to follow an advice that I found on talendforge, but not sure what it meas as I have never used maven before:
C:\Distr\Talend\Talend Open Studio V6.3.0\workspace\.Java>mvn install:install-file -Dfile=C:\Distr\Talend\Talend Open Studio V6.3.0\configuration\.m2\repository\org\apache\maven\plugins\maven-resources-plugin\2.7\maven-resources-plugin-2.7.jar -DgroupId=org.apache.maven.plugins -DartifactId=maven-resources-plugin -Dversion=2.7 -Dpackaging=jar
Scanning for projects...
------------------------------------------------------------------------
Reactor Build Order:

PROTOMIS Codes Master
PROTOMIS Routines
PROTOMIS STG_Posting (Job Designs)

------------------------------------------------------------------------
Building PROTOMIS Codes Master 6.3.0
------------------------------------------------------------------------

--- maven-install-plugin:2.4:install-file (default-cli) @ code.Master ---
Installing C:\Distr\Talend\Talend to C:\Users\MyUser\.m2\repository\org\apache\maven\plugins\maven-resources-plugin\2.7\maven-resources-plugin-2.7.jar

------------------------------------------------------------------------
Building PROTOMIS Codes Master 6.3.0
------------------------------------------------------------------------
------------------------------------------------------------------------
Reactor Summary:

PROTOMIS Codes Master .............................. FAILURE
PROTOMIS Routines .................................. SKIPPED
PROTOMIS STG_Posting (Job Designs) ................. SKIPPED
------------------------------------------------------------------------
BUILD FAILURE
------------------------------------------------------------------------
Total time: 2.960 s
Finished at: 2016-12-08T14:43:40+03:00
Final Memory: 7M/123M
------------------------------------------------------------------------
Unknown lifecycle phase "Open". You must specify a valid lifecycle phase or a goal in the format <plugin-prefix>:<goal> or <plugin-group-id>:<plugin-artifact-id>:<goal>. Available lifecycle phases are: validate, initialize, generate-sources, process-sources, generate-resources, process-resources, compile, process-classes, generate-test-sources, process-test-sources, generate-test-resources, process-test-resources, test-compile, process-test-classes, test, prepare-package, package, pre-integration-test, integration-test, post-integration-test, verify, install, deploy, pre-clean, clean, post-clean, pre-site, site, post-site, site-deploy. ->

To see the full stack trace of the errors, re-run Maven with the -e switch.
Re-run Maven using the -X switch to enable full debug logging.

For more information about the errors and possible solutions, please read the following articles:

Thanks!
7 REPLIES
Moderator

Re: Can't build a job

Hi,
So far, talend is only supported on Java CPS Versions, not Java PSU. Have you tried to revert your JDK to a Java CPS Version (such as 1.8.0_111) to see if it works?
Please check the document about:http://www.oracle.com/technetwork/java/javase/cpu-psu-explained-2331472.html.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Can't build a job

Hi,
So far, talend is only supported on Java CPS Versions, not Java PSU. Have you tried to revert your JDK to a Java CPS Version (such as 1.8.0_111) to see if it works?
Please check the document about:.
Best regards
Sabrina

Hello Sabrina,
thanks for your response.
I tried several version of Java:

jdk-8u40-windows-x64
jdk-8u111-windows-x64
jdk-8u112-windows-x64
jdk-7u76-windows-x64 (Talend did not start at all)
but the results were the same.
Moderator

Re: Can't build a job

Hi,
Have you tried to use V 6.2 to see if this issue repro(jdk-8u111)? Could you please type java -version on your cmd to see if the java environment is set correctly(jdk-8u111)?
We cannot repro your issue on our side(Window 10 64 bit).
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Can't build a job

Hi,
Have you tried to use V 6.2 to see if this issue repro(jdk-8u111)? Could you please type java -version on your cmd to see if the java environment is set correctly(jdk-8u111)?
We cannot repro your issue on our side(Window 10 64 bit).
Best regards
Sabrina

Sabrina,
could please provide me with a link to V6.2? 
I can only download V6.3 from here.
Java:
C:\>java -version
java version "1.8.0_111"
Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)
One Star

Re: Can't build a job

Sabrina,
I downloaded V6.2.1 from sourceforge and it builds jobs properly which is great!
But now we have many jobs designed in V6.3.0. When I try to export them from V6.3.0 and import to V6.2.1 I get an error:
'Job Design STG_Transactions 0.1.' from the project PROTOMIS use a more recent version of studio so cannot import it.

Is there a way to import these jobs? I hope we won't have to design all these jobs again...
Thanks again!
Moderator

Re: Can't build a job

Hi,
But now we have many jobs designed in V6.3.0. When I try to export them from V6.3.0 and import to V6.2.1 I get an error

Sorry but we forbid import of items from an upper version.
There is a way to make it but not mentioned in user manual(not supported officially)
Could you please export your jobs successfully? If so,
1. unzip your exported job, there must be job.item, job.properties and job.screenshot.
2. Go to window-->show view-->navigator, Paste three items under project -->process in your new studio V 6.2 to see if it is Ok with you?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Can't build a job

Hello,
I had the same issue
my software environment :
Windows 7Pro
Talend = 6.3.0
Java JDK= jdk1.8.0_121
JAVA_HOME=C:\Program Files (x86)\Java\jre1.8.0_121
Path begins with C:\Program Files (x86)\Java\jre1.8.0_121\bin;
I could execute the job in Talend, but I couldn't build it.
I have installed the last Talend version : 6.3.1
When I import all my projects in the new Talend, I had a message on the job which I could not built :
A module regarding Oracle Database Driver had to be installed = I let Talend download it and install it.
And then, after that, I 'm able now to build job !!! Smiley HappySmiley HappySmiley Happy
Conclusion = my problem was probably due to the lack of the Oracle module.
Nb: Pay attention on version of your jobs on the new Talend. Indeed, the new jobs recently created, were migrated and were let in version n-1.
As I have always the version 6.3.0 active, I used it to export those jobs, which were in version n-1 on the 6.3.1.
So I imported them successfully on this new Talend.
Hope this message help users like me !