Four Stars

Bug? Talend 6.3.1 contexts created by "Export as context" from hadoop cluster not working as expected. Bug?

After creating a hadoop cluster using MapR distribution and 5.2 (yarn mode) we tested for proper connectivity for hdfs,hbase, and hive.  All working fine.  We then used the "Export as context" button to have context groups created for the cluster and its connections.  Then we edited the context group to have "dev","test", and "prod" sets within it vs the "default" set created.  When we do this and then open a job that utilizes the cluster in the repository we are prompted to choose which set we want to use for each and every connection component in the job that references the cluster connections.  This also happens when we try to run the job.  This behavior did not exist in version 5.6.2. We have found a work-around for this, but it has risks and I would rather not proceed with the migration.

  • Talend Studio
2 REPLIES
Moderator

Re: Bug? Talend 6.3.1 contexts created by "Export as context" from hadoop cluster not working as expected. Bug?

Hi,

Are you using talend open studio 6.3? Could you please post some screenshot of your job setting into forum so that we can see if it is a bug on V 6.3

Best regards

Sabrina

Four Stars

Re: Bug? Talend 6.3.1 contexts created by "Export as context" from hadoop cluster not working as expected. Bug?

 

 

 

Yes

Tal1.PNG

I am unsure as to what you would like to see with regard to settings.  Could you be more specific?