7.2.1 Upgrade - Using SQL Server as the back end database

Highlighted
Six Stars

7.2.1 Upgrade - Using SQL Server as the back end database

We're upgrading from 6.4.1 to 7.2.1 at the moment.

 

Currently we utilized a PostgreSQL database, but want to begin to utilize a MS SQL Server database. I've installed the drive; formatted the URL in the Database Configuration Dialog; the Driver and URL check off green but the login fails. I'm able to open the Studio and connect to the same database with the same credentials perfectly fine. My suspicion is that in the Studio we have "Additional JDBC Parameters" set to "domain=Corp;useNTLMv2=true;ssl=require" - and that allows me to access the database using a tMSSQLInput.

 

In our 7.2.1 upgrade - I've set the URL to jdbc:jtds:sqlserver://xxxxxxxbd001:1353/talend_administrator - and this is where I get a login error.

 

I then try adding the additional JDBC parameters jdbc:jtds:sqlserver://xxxxxxxbd001:1353/talend_administrator;domain=Corp;useNTLMv2=true;ssl=require - and this gives me a connection error after a few minutes - which leads me to believe it isn't connecting at all.

 

My question is - How do we add those JDBC parameters in the TAC database URL to establish this connection? Documentation other than a straight forward URL is light to non-existent.

 

Thanks! 


Accepted Solutions
Six Stars

Re: 7.2.1 Upgrade - Using SQL Server as the back end database

and of course as soon as I posted this and opened a case...I found the solution.

 

It appears the "ssl=require" which we used in my test connection with a tMSSQLInput component and worked fine does not work in the URL for the Database Configuration in the TAC. I removed it and everything connects fine - or at least passes the "Check":

 

jdbc:jtds:sqlserver://xxxxxxxbd001:1353/talend_administrator;domain=Corp;useNTLMv2=true 

 

 


All Replies
Six Stars

Re: 7.2.1 Upgrade - Using SQL Server as the back end database

and of course as soon as I posted this and opened a case...I found the solution.

 

It appears the "ssl=require" which we used in my test connection with a tMSSQLInput component and worked fine does not work in the URL for the Database Configuration in the TAC. I removed it and everything connects fine - or at least passes the "Check":

 

jdbc:jtds:sqlserver://xxxxxxxbd001:1353/talend_administrator;domain=Corp;useNTLMv2=true 

 

 

Moderator

Re: 7.2.1 Upgrade - Using SQL Server as the back end database

Hello,

Thanks for letting us know you got the solution and sharing it with us on community.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

The Forrester Wave: Strategic iPaaS and Hybrid Integration Platforms, Q1 2019

Find out how Forrester rate different iPaaS and Hybrid Integration Platforms

Read

Talend Summer 2019 – What’s New?

Talend continues to revolutionize how businesses leverage speed and manage scale

Watch Now

6 Ways to Start Utilizing Machine Learning with Amazon We Services and Talend

Look at6 ways to start utilizing Machine Learning with Amazon We Services and Talend

Blog