Issue in studio while publishing a job

Highlighted

Issue in studio while publishing a job

Title (Problem Subject

Issue in studio while publishing a job

Symptom

java.lang.RuntimeException: org.apache.cxf.interceptor.Fault: .Problem with writing the request message, class : class java.security.DigestInputStream, ContentType : application/xml. 
> at org.apache.cxf.jaxrs.client.WebClient.doResponse(WebClient.java:1084) 
> at org.apache.cxf.jaxrs.client.WebClient.doChainedInvocation(WebClient.java:1043) 
> at org.apache.cxf.jaxrs.client.WebClient.doInvoke(WebClient.java:857) 
> at org.apache.cxf.jaxrs.client.WebClient.doInvoke(WebClient.java:831) 
> at org.apache.cxf.jaxrs.client.WebClient.invoke(WebClient.java:296) 
> at org.apache.cxf.jaxrs.client.WebClient.put(WebClient.java:314) 
> at org.talend.designer.publish.di.model.UploadableModel.upload(UploadableModel.java:165) 
> at org.talend.designer.publish.di.model.UploadableModel.uploadContent(UploadableModel.java:89) 
> at org.talend.designer.publish.di.model.UploadableModel.uploadContent(UploadableModel.java:81) 
> at org.talend.designer.publish.di.model.UploadableBundleModel.upload(UploadableBundleModel.java:18) 
> at org.talend.designer.publish.di.wizards.actions.WizardDeployHelper.deployJob(WizardDeployHelper.java:42) 
> at org.talend.designer.publish.di.wizards.actions.PublishJobWizardAction.process(PublishJobWizardAction.java:97) 
> at org.talend.designer.publish.core.actions.AbstractPublishJobAction.exportJobForPOJO(AbstractPublishJobAction.java:185) 
> at org.talend.designer.publish.core.actions.AbstractPublishJobAction.run(AbstractPublishJobAction.java:98) 
> at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:466) 
> at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:374) 
> at org.eclipse.jface.wizard.WizardDialog.run(WizardDialog.java:1059) 
> at org.talend.designer.publish.di.wizards.PublishJobWizard.publishToRepository(PublishJobWizard.java:70) 
> at org.talend.designer.publish.di.wizards.AbstractPublishWizard.performFinish(AbstractPublishWizard.java:120) 
> at org.eclipse.jface.wizard.WizardDialog.finishPressed(WizardDialog.java:853) 
> at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:438) 
> at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:619) 
> at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248) 
> at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84) 
> at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4188) 
> at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1467) 
> at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1490) 
> at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1475) 
> at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1279) 
> at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4031) 
> at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3658) 
> at org.eclipse.jface.window.Window.runEventLoop(Window.java:832) 
> at org.eclipse.jface.window.Window.open(Window.java:808) 
> at org.talend.designer.publish.di.actions.AbstractPublishAction.doRun(AbstractPublishAction.java:118) 
> at org.talend.repository.ui.actions.AContextualAction$2.run(AContextualAction.java:632) 
> at org.talend.repository.RepositoryWorkUnit.executeRun(RepositoryWorkUnit.java:99) 
> at org.talend.core.repository.model.AbstractRepositoryFactory.executeRepositoryWorkUnit(AbstractRepositoryFactory.java:258) 
> at org.talend.repository.localprovider.model.LocalRepositoryFactory.executeRepositoryWorkUnit(LocalRepositoryFactory.java:3311) 
> at org.talend.repository.svnprovider.SvnRepositoryFactory.executeRepositoryWorkUnit(SvnRepositoryFactory.java:334) 
> at org.talend.repository.remoteprovider.RemoteRepositoryFactory.executeRepositoryWorkUnit(RemoteRepositoryFactory.java:793) 
> at org.talend.core.repository.model.ProxyRepositoryFactory.executeRepositoryWorkUnit(ProxyRepositoryFactory.java:2080) 
> at org.talend.repository.ui.actions.AContextualAction.run(AContextualAction.java:641) 
> at org.eclipse.jface.action.Action.runWithEvent(Action.java:519) 
> at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:595) 
> at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:511) 
> at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:420) 
> at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84) 
> at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4188) 
> at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1467) 
> at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1490) 
> at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1475) 
> at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1279) 
> at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4031) 
> at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3658) 
> at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1151) 
> at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332) 
> at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032) 
> at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148) 
> at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636) 
> at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332) 
> at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579) 
> at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)

Diagnosis (Root Cause)

This is mainly a connection issue between the studio and the Nexus Repository

Solution/Workaround

You need to check if you can publish other jobs to your Nexus.

 

If you cannot, can you check your TAC and make sure for the user libraries and artifact repository is set to the following URL String exactly, "http://<Nexus URL>:8081/nexus/"

 

Moderator

Re: Issue in studio while publishing a job

Hello,

Thanks for sharing solution with us.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Two Stars

Re: Issue in studio while publishing a job

Hi 

 

I am currently facing this issue.

I am using Talend Studio 6.3.1

it's happening for all jobs.

I already put "/" at the very behind of my URL repository for both snapshot and release

 

this happened after I create new workspace.

it's totally fine with the old one.

 

can anyone help?

Moderator

Re: Issue in studio while publishing a job

Hello,

Are you able to open nexus in your local browser(http://localhost:8081/nexus/)? Have you already created a case on talend support portal?

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 3

Read about some useful Context Variable ideas

Blog

Talend Studio Improvements for API Services

Taken a look at the Talend Studio improvements for API Services

Watch Now

Data Integration Success Stories

Take a look at some Data Integration success stories

Read

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch