unable to open existing project

One Star

unable to open existing project

I am running on Windows 7. With both talend 4.03 (r47759) and 4.1.0 (r49467) I am unable to open a project that I previously created. What's odd is that I worked on the project for several weeks, opening and closing it many times and never had any issues. Here is what .metadata/log is showing:
!SESSION 2010-10-08 11:43:57.046 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_18
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86
!ENTRY org.eclipse.core.resources 2 10035 2010-10-08 11:43:58.635
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.
!ENTRY org.talend.libraries 4 0 2010-10-08 11:44:28.525
!MESSAGE 2010-10-08 11:44:28,522 ERROR org.talend.commons.exception.ExceptionHandler -
!STACK 0
java.lang.NullPointerException
at org.talend.repository.localprovider.model.LocalRepositoryFactory.doesLoggedUserExist(Unknown Source)
at org.talend.repository.localprovider.model.LocalRepositoryFactory.logOnProject(Unknown Source)
at org.talend.repository.model.ProxyRepositoryFactory.logOnProject(Unknown Source)
at org.talend.repository.ui.login.LoginDialog$1.run(Unknown Source)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
I tried deleting the workspace and reimporting but the error persists. I reinstalled version 4.1.0 fresh and I continue to get the error.
I was very happy with the product and ready to buy some pro licenses but not being able to open a project with 2 weeks worth of work in it is giving me second thoughts.
any suggestions?

Re: unable to open existing project

Have you tried importing the jobs (not the project) into a new project? you can point the importer at your previous workspace.
One Star

Re: unable to open existing project

I think I tried that but its not letting me import:
1. I created a new project
2. Right clicked on "Job Designs" and selected "Import Items".
3. Selected "select root directory" and browser to my project
4. It shows me *some* of the Jobs in my old project.
5. check the jobs.
6. the "finish" button is not clickable (e.g. its greyed out) so I can't actually import. Next to the words "Items List" it says in red: "no valid items found in current source".
Did I do something wrong?

Re: unable to open existing project

no, thats what I was thinking. Sounds like something in your project is corrupt. Maybe importing one job at a time will help you zero in on the problem.

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog