tsalesforceconnection "UNEXPECTED_EXCEPTION"

Four Stars

tsalesforceconnection "UNEXPECTED_EXCEPTION"

HI,

 

Wile trying to connect to salseforce i get this error "UNEXPECTED_EXCEPTION", although i succeeded  at adding the salesforce to the project metadata.

I am using the TOS 7.0.1.

 

Capture.PNGk.PNG

 

 

why i am having this error ?

Thanx for ur answers.

Forteen Stars TRF
Forteen Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

Your setting looks OK.

Are your context variables assigned to the job?


TRF
Four Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

when i drag the component tsaleforce from my metadata to the job, i get the error and and the context variables are not assigned to the component although they are assigned to the job.

 

Thnx

Thirteen Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

@laissaouioussam,i suggest you to chnage to Built In and provide the contexts and execute the job.it will work.

Manohar B
Four Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

p.PNG

Forteen Stars TRF
Forteen Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

OK, context variable are assigned to the job and of course, they have a value (a least for those required by tSalesforceConnection), right ?


TRF
Four Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

@TRFyes they do

what does it seem to be the problem ?

Forteen Stars TRF
Forteen Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

Did you tried what @manodwhb suggest you?


TRF
Four Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

@TRFit does but i need to do that with context variable

Forteen Stars TRF
Forteen Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

Using the connection by reference (from the repository) and using context variables to populate the required field are 2 differents things.

Of course you are able to have a built-in connection using your context variables.

If it works, you're right.


TRF
Four Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

well i used BUILD-IN this time and tried to run the job, nothing happen it wouldn't run

i closed the project  and reopen it and when i tried to run the job i had the error "UNEXPECTED_EXCEPTION"

 

Thanx

Highlighted
Forteen Stars TRF
Forteen Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

???
Can you try the same using the previous TOS version?

TRF
Four Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

i was thinking about that

i will download previous TOS version and import the project

 

 

Thanx

Forteen Stars TRF
Forteen Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

You cannot import a version n project to a version n-1 of the Studio.

Just test with a mini job for checking.


TRF
Thirteen Stars

Re: tsalesforceconnection "UNEXPECTED_EXCEPTION"

@TRF,yes i was using with contexts after drag the connection into job.

Manohar B