tkafkainput - "Stop after receiving a maximum number of messages" does not work

Five Stars

tkafkainput - "Stop after receiving a maximum number of messages" does not work

The tKafkaInput component in my job does not stop after the specified number of messages in the "Stop after receiving a maximum number of messages" setting.

 

I have 180 messages in the queue, and I want to stop after getting the first 10, but it always gets all 180 no matter what number I choose.

 

Have I used this setting incorrectly? Any thoughts?

 

Screen Shot 2018-09-26 at 8.25.46 am.pngScreen Shot 2018-09-26 at 8.26.51 am.png

 

Five Stars

Re: tkafkainput - "Stop after receiving a maximum number of messages" does not work

bump
Moderator

Re: tkafkainput - "Stop after receiving a maximum number of messages" does not work

Hello,

From your screenshot, we don't find any incorrect setting. Could you please clarify in which Talend version/edition you are? We will make a testing on it to see if it is a bug.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: tkafkainput - "Stop after receiving a maximum number of messages" does not work

I'm using: Talend Open Studio for Big Data - Version: 7.0.1

 

Thanks.

Moderator

Re: tkafkainput - "Stop after receiving a maximum number of messages" does not work

Hello,

Could you please try to download talend open studio for bigdata product 7.1.1 to see if this issue repro?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: tkafkainput - "Stop after receiving a maximum number of messages" does not work

Yes, and I can confirm this is still a problem in Talend Open Studio for Big Data 7.1.1.

Moderator

Re: tkafkainput - "Stop after receiving a maximum number of messages" does not work

Hello,

Could you please try one of the message batches option (stop after a max total duration, stop after receiving a maximum number of messages, stop after max time between messages) in Talend Open Studio for Big Data 7.1.1.?

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Put Massive Amounts of Data to Work

Learn how to make your data more available, reduce costs and cut your build time

Watch Now

How OTTO Utilizes Big Data to Deliver Personalized Experiences

Read about OTTO's experiences with Big Data and Personalized Experiences

Blog

Talend Integration with Databricks

Take a look at this video about Talend Integration with Databricks

Watch Now