Five Stars

third party Jars Intallation

Hi

I'm using Talend 6.0 enterprise version. 

And in a job am using a third party jar known as interpreter. When I run a job it supports as expected and my job return a  expected result.

But When I export my job and deploy on linux server it doesnt work and shows some type error. Because am using one of the method in a job from a jar class.

 

When I checked a module list, In that list that jar's status was showing not installed on local.

 

May I know, Is there any option or approach so that I could use the same jar functionality in my job after export and deploy on linux server ? Is it correct, to use hat jar in other environment, jar should be successfully installed in modules feature of Talend ?

 

Thanks

 

 

 

 

  • Data Integration
3 REPLIES
Moderator

Re: third party Jars Intallation

Hi,

Did you export your job as script file(.sh) and run it on your linux server (commandline)or deploy your job on Nexus server or job conductor?

Best regards

Sabrina

Five Stars

Re: third party Jars Intallation

No...From svn, After creating a Tag then I had deployed on linux server. But when I ran a job in linux environment its not working and showing class's method error which I am using in my job. Is there anything I could do so that while deployment all third parties jars could also available on other environment.?  DO I need to install them first on modules list of jars..?  Any other thing I could do...?

 

Thanks

Seventeen Stars

Re: third party Jars Intallation

I guess you have build the job with the TAC (command line).

The problem what you are facing is a bug, which frequently occurs.

Actually the studio should push the library into the nexus or SVN lib repository (I always recommend using the nexus because it is faster and a SVN is actually not the right place for binaries).

Please check the configuration in the TAC where the user libs are located (Nexus or SVN) and check if you can find it there.

Your error description shows me, it has not reached this place.

You can - if the studio will not push it, always push your lib manually to the nexus or the SVN. Mostly this is more reliable as the studio does the job for you.