One Star

talend taking too long to load

Hey!
I am using talend 4.1.2 on linux (ubuntu 10.10) 64 bit and talend is taking about 5m to load.
To load I mean just the initial screen where I select the project. I recently placed the project folder under svn, does talend read all the files in the project folder or something? This is seriously getting irritating.
Hope any can help me.
Thanks
15 REPLIES
Seven Stars

Re: talend taking too long to load

I have the same problem with TIS 4.0.3 on Win 7 64-bit when launching the studio for the first time after rebooting...
One Star

Re: talend taking too long to load

I have all the time not when I start it for the first time. After opening if I close it and reopen it it takes the same time to load and I think it's getting worse
Highlighted

Re: talend taking too long to load

Same problem here with TIS 4.0.2, 4.0.3, 4.1.1 and 4.1.2
One (old-school) way to improve start-up times is to remove unused components from your palette-- while this improves the "generation engine" phase of loading, it does not improve the initial start-up.
Do any of you have McAfee or encrypted file systems installed?
Our SVN server is not the fastest thing in the world, and I've always suspected that active virus scanners and other low-level software may play a role in the long start times.
I see poor start-up (pre generation engine load) performance when using a SVN hosted project, and slightly better (but still very slow) performance with a local project.
There are no errors thrown, it appears that the majority of the time is spent in the loading status: "Load Components...."
Four Stars

Re: talend taking too long to load

I'm using 4.1.2 on both Win and Ubuntu. I can confirm as well this looong start up time.
But to me, what is way way more frustrating is the performance of Schema Editor on Linux. It has such a painfull delay (scrolling, changing window size, changing column size, listing dropdown menus) that it's almost impossible to work with it.
On Win it works just fine. Is it something about Java?
Seven Stars

Re: talend taking too long to load

I'm running 4.0.3 on Win7 64-bit with McAfee. While the project load and generation engine are not exactly fast, the main delay (starting the studio for the first time each reboot) is even bringing up the splash-screen and then workspace/project selection dialog box.
Six Stars

Re: talend taking too long to load

Well I agree that with time the Eclipse platform seems to become slower and slower... sometime is insanely and embarrassingly slow also on powerful workstations also for basic tasks like code completion...
Seven Stars

Re: talend taking too long to load

with time the Eclipse platform seems to become slower and slower

What do suggest doing about this: re-installing the studio or wiping the workspace or both or recreating the project?
A number of users here have also started experiencing the studio appearing to simply hang while attempting various (seemingly unrelated) tasks but if we click Close Window and then Wait for Program to Respond, it appears to revive itself. I wonder if this is related to your comment.
One Star

Re: talend taking too long to load

Hi,
I'm surprised to see a relatively number of posts on this subject. I've got 3 projects in a local repository and talend is taking about at least 15 minutes to load the initial project selection screen. I just cannot believe that this is an eclipse related issue. It's an extremely annoying situation.
best regards.
Six Stars

Re: talend taking too long to load

with time the Eclipse platform seems to become slower and slower

What do suggest doing about this: re-installing the studio or wiping the workspace or both or recreating the project?
A number of users here have also started experiencing the studio appearing to simply hang while attempting various (seemingly unrelated) tasks but if we click Close Window and then Wait for Program to Respond, it appears to revive itself. I wonder if this is related to your comment.
Well... I think that the eclipse platform is too much bloated... so I think there isnt a quick fix.... also other projects based on eclipse are generally quite slow... and seems to get slower with then number of components / file added...
In comparison Netbeans platform on the same machines "feels" and respond much better...
One Star

Re: talend taking too long to load

ttezeroglu: Mine is taking longer now Smiley Sad It used to take 5m and now it's moving up to about 20m or more. I really can't understand why. I have a big project with many jobs... but still.. such a long time to just load the stuff....
Seven Stars

Re: talend taking too long to load

Re our studios appearing to simply hang: that turned out to be something to do with Subversion.
One Star

Re: talend taking too long to load

Alevy: My project is under svn but I am using the community version so there is no svn incorporated in talend. What was the problem with svn???
Seven Stars

Re: talend taking too long to load

We never found out: support just said "According to your logs it appears that the issue may lie within your repository".
After a failed upgrade to v4.1.2, we restored the previous day's Subversion backup and the problem never happened again...
One Star

Re: talend taking too long to load

Huummm I am now using v4.1.2 and only had a problem with the milestone version (http://www.talendforge.org/forum/viewtopic.php?id=13859) which I foolishly used on my main project I was able to recuperate my project by manually editing the xml files.. but I don't see how this can slow down talend... Smiley Sad
It gives me an excuse to go for a cup of coffee and a walk around the building I guess Smiley Tongue
Seven Stars

Re: talend taking too long to load

Since we upgraded to v4.1.2 (with the 29/04 integrated patch) starting the studio for the first time each reboot (bringing up the splash-screen and then workspace/project selection dialog box) is much faster, within what I consider acceptable for Win 7 Professional 64-bit on i7 CPU @ 2.8GHz with 8Gb RAM (and also even within an XP emulator on the same machine).