tWriteJSonField has error "Loop Element is missing."

One Star

tWriteJSonField has error "Loop Element is missing."

When I Click "Configure JSON Tree" to open the XML tree editor it comes up in grey and shows an error "Loop Element is missing."
I checked the documentation for tWriteJSonField and could not find any reference to this error.
I am using TOS ESB 5.3.0
Any help is appreciated.
Thanks in advance!
Moderator

Re: tWriteJSonField has error "Loop Element is missing."

Hi,
You should set "Loop element" (move your mouse on the element you want to set and right click ) when you config your JSON Tree.
Please see the online component reference tWriteJSONField and the use case scenario retrieving_error_messages_while_extracting_data_from_JSON_fields
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: tWriteJSonField has error "Loop Element is missing."

Hi,
I tried to create JSON document using twriteJsonField Component, I have applied group by on single column and based on that I want to set loop for column which has multiple values. I tried all the combination but not get required output.
let consider ex. we have two tables user and address table
User table : userID,name,desingation
address table: addressID,userID,street,city,state,country.
consider one user say user1 has two address. so we want json to have address array which contains both address.
required Json: {"userid":1,"name":"",Addess:}
Please provide suggestion.
Thanks!

Calling Talend Open Studio Users

The first 100 community members completing the Open Studio survey win a $10 gift voucher.

Start the survey

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog

How Media Organizations Achieved Success with Data Integration

Learn how media organizations have achieved success with Data Integration

Read

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.

Download