tWebservice "anytype" type reply

Five Stars

tWebservice "anytype" type reply

Hi everybody,

 

So I have been using Talend for a bit now. After lots of problems, I have finally managed to make a connection to a wsdl webservice, but now I am having problems with the reply.

The developer, don´t ask me why, decided that the reply from the webservice that I am trying to use would be "anytype", so whenever I try to map it to a variable, I get a popup like this

Anytype.JPG

The problem is that I know that the reply is 1 or 0 ,but it doesn't matter what I bind (string, integer, normalizedString, boolean), I am getting a null as a reply. At the beginning I thought that I was just giving the wrong parameters as input for the webservice, but it looks like that is correct.

Do you have any idea if this "anytype" is not supported by Talend or if I should try an specific type that can take any type?

 

Best Regards,

JNanin

 

 

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog