One Star

tSplitrow component loses all mapping every time after reopening job

Hi Team,
I am using tSplitrow and every time when I reopen the job the component loses all the mapping provided in it
I strongly believe its a bug, if not then pls let me know what I need to do, to have the mappings permanently.
Pls have look at images attached.
Thanks in advance,
Navali.
10 REPLIES
Community Manager

Re: tSplitrow component loses all mapping every time after reopening job

Hi
Which OS? Which version?
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: tSplitrow component loses all mapping every time after reopening job

Hi Shong,
I have Windows 7 OS and using Talend 5.1.1(r84309) Cluster edition.
Thanks,
Navali.
Community Manager

Re: tSplitrow component loses all mapping every time after reopening job

Hi Navali
I am trying to reproduce this issue on Windows 7 with v5.1.1. In the mean time, I have a question, I see you configure the columns mapping in a component called tSplitRow_4, but you show me a component called tSplitRow_2 in your third picture. Can you please check it?

Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: tSplitrow component loses all mapping every time after reopening job

Hi Shong,
Both tSplitRow_2 and tSplitRow_4 are the components of same job and both have same problem.
Thanks,
navali.
Community Manager

Re: tSplitrow component loses all mapping every time after reopening job

Hi Navali
I find a related issued in our bugtracker
https://jira.talendforge.org/browse/TDI-8504
But I don't reproduce the problem on Windows 7 64 bit with v5.1.1.
Have you tried to re-start Talend Studio? If the problem always exist, can you please export your job and send it to me via email?
Thank you!
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: tSplitrow component loses all mapping every time after reopening job

Hi Shong,
I have sent you my job via mail, kindly check.
Thanks,
navali
Community Manager

Re: tSplitrow component loses all mapping every time after reopening job

Hi
I have imported your job into my studio on 64bit windows 7, and then try to modify the column mapping, save it, close the job and reopen it again, but it works fine, don't lose the column mapping. I don't have a 32bit widows7 machine for testing now yet. Well, can you please try the following ways and see if the problem still exist,
1. Add a tLogRow component after tSplitRow.
2. Install a new Talend Studio and test it.
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: tSplitrow component loses all mapping every time after reopening job

Hi Shong,
As suggested by you, I have done both the changes but sadly issue still exists.
Pls restart your Talend studio and check for some more times, I am pretty sure you will be able to reproduce the issue.
if possible pls check with Windows7 on 32 bit machine.

Thanks in advance,
Navali.
Community Manager

Re: tSplitrow component loses all mapping every time after reopening job

Hi Navali
It is really a bad news.;( do you always get the same problem even though you create a new job? Do you have a chance to migrate your job to another system and test it? I tested it on a 64-bit windows7 and it works, I don't have a 32-bit windows7 machine for testing now yet.
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: tSplitrow component loses all mapping every time after reopening job

Shong,
Currently I have only one job with tSplitRow. I will test this job on 64 bit machine and let you know.
anyways thanks for your time and efforts.
Navali.