tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Four Stars

tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hi Community,

 

I am trying to connect Talend to Salesforce by using tSalesForceConnection component with my salesforce playground credentials.

And i always get the error message as :

 

connecting to socket on port 3372
connected
Exception in component tSalesforceConnection_1
java.lang.RuntimeException: com.sforce.ws.ConnectionException: Failed to send request to https://www.salesforce.com/services/Soap/u/37.0
at local_project.test_salesforce_connection_0_1.Test_Salesforce_connection.tSalesforceConnection_1Process(Test_Salesforce_connection.java:365)
at local_project.test_salesforce_connection_0_1.Test_Salesforce_connection.runJobInTOS(Test_Salesforce_connection.java:650)
at local_project.test_salesforce_connection_0_1.Test_Salesforce_connection.main(Test_Salesforce_connection.java:484)
[FATAL]: local_project.test_salesforce_connection_0_1.Test_Salesforce_connection - tSalesforceConnection_1 com.sforce.ws.ConnectionException: Failed to send request to https://www.salesforce.com/services/Soap/u/37.0
[statistics] disconnected

 

I am able to access salesforce.com with the same credentials in a browser but not in Talend.

I would really appreciate any help with this.

 


Accepted Solutions
Forteen Stars TRF
Forteen Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Can you try to connect to Salesforce using data loader? If it works, the problem is local to TDI. Else, it's probably due to a proxy you need to cross to access Internet.
Maybe your colleagues are not on the same network you are. To be sure, you can also try using your mobile as access point to bypass any network component.
Here a link to a similar question I solved to someone in the past https://www.talendforge.org/forum/viewtopic.php?id=53151
Hope this helps.

TRF

All Replies
Forteen Stars TRF
Forteen Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hi,

Are you try to connect to a production or a sandbox environment?

If trying to a sandbox, change the Salesforce URL to "https://test.salesforce.com/services/Soap/u/38.0".

Hope this helps.


TRF
Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

I have tried with test.salesforce.com/services/Soap/u/38.0 as well. It
still shows the same error Smiley Sad
Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

I failed to mention. I am using Talend DI 6.3.1 version.

Forteen Stars TRF
Forteen Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Does this error arrives immediately or do you have to wait for some seconds before?

Do you have configured any proxy to touch Salesforce (using tSetProxy) or not?

Are you sure about the version (37 or 38)?

Else, can you share the job?


TRF
Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

It takes few seconds to throw this error.

And I haven't done any proxy settings with tSetproxy. Do I have to do that ?
But I tried the same job from my colleagues system and it just connected
without any proxy settings in DI 6.3.1
I am not sure what is the exact solution though.

Capture.PNG

 

 

 

Forteen Stars TRF
Forteen Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Can you try to connect to Salesforce using data loader? If it works, the problem is local to TDI. Else, it's probably due to a proxy you need to cross to access Internet.
Maybe your colleagues are not on the same network you are. To be sure, you can also try using your mobile as access point to bypass any network component.
Here a link to a similar question I solved to someone in the past https://www.talendforge.org/forum/viewtopic.php?id=53151
Hope this helps.

TRF
Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hi TRF. In Windows Services there was a setting which disabled access to cloud service due to which I couldn't connect to salesforce.
After aborting it the connection was successful.
Thanks for the help. I really appreciate it.
Forteen Stars TRF
Forteen Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Great!
Thank's for sharing this tip

TRF
Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hi Vishwa04 , I am facing similar issue .  Where in the windows services , I can find out this setting?

 

Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

I am facing similar issue .  Where in the windows services , I can find out this setting?

 

Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

I am facing the same issue in production server. Please let me know where exactly in Windows services we need to disable the access to cloud service?

Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

I am facing the same issue in production server. Please let me know where exactly in Windows services we need to disable the access to cloud service?
Moderator

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hello,

And are you using context mode in your connection also when create a salesforce connection?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

I tried with both context and metadata salesforce connection . But still no luck.

Moderator

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hello,

Can you successfully connect to your salesforce through data loader without using talend tool?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Forteen Stars TRF
Forteen Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hi,

 

Did you check the basics:

- connect using DataLoader

https://login.salesforce.com for production connection

https://test.salesforce.com for sandbox connection

- tSetProxy if any proxy before to go to the internet


TRF
Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Thank You for your reply.

 

I checked the below options suggested by TRF.

 

- connect using DataLoader     -     It's not connecting from data loader(same error) .This connection is working from other servers.

https://login.salesforce.com for production connection   -  From Salesforce browser with same credentials it's working

https://test.salesforce.com for sandbox connection  -  From Salesforce browser with same credentials it's working

- tSetProxy if any proxy before to go to the internet  - Tried this but getting but getting a java error.

 

Could you please suggest me any alternate solutions?

Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hi Team,

 

I am getting the same issue while connecting to Salesforce.

My job is running on the Production and is hosted on Unix Server.

 

Kindly let me know the solution on this.

 

Please find the attached job for the same.

 

 

Six Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hi,

 

I am having the same issue currently.  The job has been scheduled and running for several weeks now but this weekend it failed with this error message.  

I was wondering that it might be a Windows Service that you mentioned.  Could you share which Windows Service you aborted to fix this issue?

 

Thanks much for anyone's help.

Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

I am having the same issue. The workflows have been running without issue for months.

 

Any assistance is appreciated  

Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hi,

I was able to fix this issue by changing url from "https://www.salesforce.com/services/Soap/u/39.0" to "https://login.salesforce.com/services/Soap/u/39.0"

Thanks,

Mahendra

Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hi Mahendra_W,

 

Yes, Its working for me also.

 

Thanks for sharing.

 

Six Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hi guys,

 

This works for me.  Thanks so much!

 

Does anyone know what had caused the issue?

Five Stars BRM
Five Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

This fixed the problem for me.  Thank you.

Six Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hi Vishwa, please let me know the service name exactly which one you enable for this to work. You are my last hope. I am getting similar error and tried so many things to resolve without success..Thanks in advance

Four Stars

Re: tSalesforceconnection issue. Failed to send request to https://www.salesforce.com/services/Soap/u/37.0

Hi All,

Sorry for late reply.
You can try disabling/aborting below windows services
Services->
Netscope client- abort
Umbrella roaming client- abort


Vishwa