tSSH usage ?

One Star

tSSH usage ?

I'am Jean-Luc and that's my first post in this forum. Sorry for my english, I'am French and not realy easy with english writing.
I work on a linux box (RedHat AS) with a TOS 3.0.3 and on java projects. I have a good understanding of TOS as I work with it for few month now.
I experiment some troubles with tSSH. I have created a new job, add a single tSSH component, make the configuration : Host, Port (default), User, Authentication method (public key or password), key Passphrase (default) and Private key or password (depending on Authentication method).
Then run the job...
The component seems to work fine... but does nothing on the server I am connecting.
If I made an error on its configuration, I have troubles : fine. So it find the server and the login process is OK (with password or with public key).
I did not change the default command : "echo Talend Open Studio" but nothing is printed in the console.
If I tried to sent a scrip command, I never see any action on the server !
Where is my mistake ? Should I add some component to see the result ? In that case how should I connect it to the tSSH component ?
Tanks for your help.
PS : I already have the trouble with precedent release of TOS.
One Star

Re: tSSH usage ?

I'm not about what you tried to do...
Here is my experience with the tSSH component. In fact, I used it to launch a script from a computer (my machine), on the Unix remote server. This script will generate a file. After this, I FTPGet the file, and ... so on...
I never used the default setting of tSSH. But, can you try this command : "echo Talend Open Studio > testfile" and then see on your remote machine if the testfile exists ?
For me, but I may be wrong, it normal to not see anything printed, because, you obviously don't use the same tty...
One Star

Re: tSSH usage ?

Thanks very much for your answer. It works perfectly in fact as you suggest.
My problem is that the command I want to execute is not launch. I can write other command script that are run. But the one I want is not.
The difference between the different script is that the one that not work call a sudo command !
It seem that it must be launch from a terminal on the server. I don't know how to resolve the problem. I think the .baschrc (and other kind of script) are only read by during a connexion with a terminal.
I guess the trick should be to read some configuration's file while connecting with the component tSSH, but I don't know which one.
One Star

Re: tSSH usage ?

tSSH needs to work similarly to tSYSTEM in that the out put of the command can be sent to the console or directed into a connection to another component. It is not very usefull just to be able to run a script and return the exit status.
Also have had lots of problems being able to use tSSH to connect to SuSE Linux 9 and 10.
Dave Venus


Talend named a Leader.

Get your copy


Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables


Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema


Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables