tRESTClient logs missing while running job from bash script

One Star

tRESTClient logs missing while running job from bash script

I have exported a job contains tRESTClient with checked print log option. The job works fine while running from Talend Studio printing all the logs required. But while running the exported job through command line on the terminal, the request and response logs for tRESTClient are missing. It just prints stdout and stderr streams. Seems like these component logs are not acting as stdouts for the talend jobs. How can i fix this?
Thank you!
Community Manager

Re: tRESTClient logs missing while running job from bash script

Hi
Which version are you using? I tested this issue with v5.5.1 and I can see the log message when the job is executed through command terminal.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: tRESTClient logs missing while running job from bash script

I'm also using TOS for Data Integration version 5.5.1.
The trouble is only with the tRESTClient request and response logs. All other logs are getting printed. Is there anything other i've to do except checking the print logs option in tRESTClient settings?
Community Manager

Re: tRESTClient logs missing while running job from bash script

Hi 
I can see the request and response logs are getting printed when the job is executed from the command terminal, see image:
 
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: tRESTClient logs missing while running job from bash script

Hi Shong,
Here is the snapshot of my terminal, you can see the log4j warnings i'm getting here. But i'm getting the same warnings when i run the job from TOS, still the logs were printing in the TOS but not here on terminal. How should i get rid of these warnings? I think it is responsible for the problem i'm facing.

Thanks!
One Star

Re: tRESTClient logs missing while running job from bash script

Seems like my image is not getting upload.
Community Manager

Re: tRESTClient logs missing while running job from bash script

Hi 
Have you activated the log4j feature in Talend Studio? Can you show me a screenshot of your job and the log message printed on the console when you execute the job in studio?
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: tRESTClient logs missing while running job from bash script

Hi Shong, logs are getting printed in TOS.
One Star

Re: tRESTClient logs missing while running job from bash script

I found another thread with similar problem. Check this out.
https://talendforge.org/forum/viewtopic.php?id=33861