One Star

tREST and tRESTClient in the same job causing issues

First I built my job with only tRESTClient. It works fine. Then I have an URL/API call that doesn't work with tRESTClient, but does work with tREST. So just for that one API call I use tREST which it does work for but, in doing so it caused all my tRESTClients break. The error I get is "The method getHeaders() is undefined for the type Response". I tried making the tREST as a subjob, but the error still occur.
5 REPLIES
Moderator

Re: tREST and tRESTClient in the same job causing issues

Hi mchiosi,
Would you mind uploading your current job design screenshots into forum which will be helpful for us to address your issue.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: tREST and tRESTClient in the same job causing issues

Here are screenshots of part of the main job and all of the subjob. If I turn off the subjob Concur_ED_Pull all of the tRESTClients work fine. Only when I include a tREST does the main job have this getHeaders() issue. As I mentioned before I would use another tRESTClient, but the current version of this API does not work with tRESTClient and for some reason does work with tREST.
 
One Star

Re: tREST and tRESTClient in the same job causing issues

Hi all!
I'm getting same cause using v5.6. Have anyone fixed this problem? Or some workaround about it.
Thanks,
Not applicable

Re: tREST and tRESTClient in the same job causing issues

Same problem here on 5.6.1
Still no workaround/fix?
Two Stars

Re: tREST and tRESTClient in the same job causing issues

Any solution to this problem? Same problem I encounter using 5.6.2 Open Studio. I can't execute tRest and tRestClient at the same time in a job. Tried putting the tRestClient in a separate job as the child job but still to no use.

 

Appreciate any help.

 

thanks,

-chim