tPop with MS Exchange server

One Star jmd
One Star

tPop with MS Exchange server

Hi,
We use tPop to get messages from an MS Exchange server, with filters applied on source and destination email address
Depending on the POP account (Exchange account) used to get the messages, messages are sometimes not retrieved and we can't understand why
Did someone have an experience with similar problems ?
Thanks for your help
Moderator

Re: tPop with MS Exchange server

Hi,
Could you give us your tPop setting screenshots including the filter one, thanks a lot.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star jmd
One Star

Re: tPop with MS Exchange server

Here are 2 screenshots of the tPop configuration :
https://docs.google.com/file/d/0B15XMMEHVcFlNHR4aldiSnJfekk/edit
https://docs.google.com/file/d/0B15XMMEHVcFlZW1NZUFjUHFfSWM/edit
But it won't help you
I think the problem is in the Exchange account configuration
So I need experience feedback with Exchange
One more thing : the mails go through Exchange "distribution groups" to the account we connect to : perhaps is there a problem with this Exchange feature ???
Moderator

Re: tPop with MS Exchange server

Hi,
I suspect the connection with Exchange server is not successful. I have seen your screenshot and found that you used context variables. Is it successful using value without context variables? Is it correct information for tPOP Host, Port and Username and Password?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: tPop with MS Exchange server

Hi,
I have a problem with Talend and Microsoft Exchange that looks like a very near problem as this bug.
User and Pwd are correct.
Port is ok and IP too.
But when I launch the Talend Job I have this response:
sh ReceptionneurMailCommande_run.sh
Exception in component tPOP_1
javax.mail.MessagingException: Connect failed;
nested exception is:
java.io.IOException: Unexpected response: 220 WEXC602.cov.dom Microsoft ESMTP MAIL Service ready at Thu, 3 Jul 2014 14:16:36 +0200
at com.sun.mail.pop3.POP3Store.protocolConnect(POP3Store.java:210)
at javax.mail.Service.connect(Service.java:295)
at talendpierre.receptionneurmailcommande_0_1.ReceptionneurMailCommande. tPOP_1Process(ReceptionneurMailCommande.java:299)
at talendpierre.receptionneurmailcommande_0_1.ReceptionneurMailCommande. runJobInTOS(ReceptionneurMailCommande.java:937)
at talendpierre.receptionneurmailcommande_0_1.ReceptionneurMailCommande. main(ReceptionneurMailCommande.java:827)
Caused by: java.io.IOException: Unexpected response: 220 WEXC602.cov.dom Microso ft ESMTP MAIL Service ready at Thu, 3 Jul 2014 14:16:36 +0200
at com.sun.mail.pop3.Protocol.readResponse(Protocol.java:711)
at com.sun.mail.pop3.Protocol.simpleCommand(Protocol.java:656)
at com.sun.mail.pop3.Protocol.<init>(Protocol.java:109)
at com.sun.mail.pop3.POP3Store.getPort(POP3Store.java:261)
at com.sun.mail.pop3.POP3Store.protocolConnect(POP3Store.java:206)
... 4 more
But when we connect with Telnet on the Microsoft Exchange Server, it works.
Thanks for your help.