One Star

tOracleOutputBulkExec commits

I am very new to Open Studio and currently working on some proof of concepts. My job involes extracting data from Teradata and moving it into Oracle using OracleOutputBulkExec. Everything is working fine in the process but the data is not being committed to the Oracle table -- I killed the process after 32k rows. My question is: Is there a way to control the commit levels for this module similar to how it works in tOracleBulkExec?
Thanks
4 REPLIES
Employee

Re: tOracleOutputBulkExec commits

Hello,
OracleOutputBulkExec works in two steps. Firstly it writes all rows to a temporary file then it load all the file to the database.
I think that you stop your job while the file was still being created.
SqlLoader default is to commit every 50 rows.
Since 2.2.0M2 you can change this value in a Java project using the OracleBulkExec "Rows per commit" key in Parameter options.
Regards,
Michaël.
One Star

Re: tOracleOutputBulkExec commits

Thanks for the reply!
I did stop my job too soon but have since re-run with a smaller subset and determined exactly what you said. However, I still do not see any way to set Rows per Commit or BINDSIZE with OracleOutputBulkExec. I do see it and have used the option in OracleBulkExec.
Are you saying that I should explicitly write to a file and then use OracleBulkExec in order to control these options. It seems that OracleOutputBulkExec should give me those options.
Employee

Re: tOracleOutputBulkExec commits

tOracleBulkExec Parameter is a new option. It will be reported in tOracleOutputBulkExec in version 2.2.0M3.
In the interval you have to use tOracleOutputBulk to prepare your file and then a tOracleBulkExec.
Remember that 2.2.0 M2 is not a stable release but an image of our current development for 2.2.0 final which will be available the 5th of October.
It allows you to study some of TOS new functionalities but you might experiment some bugs or inconsistent behaviors...
The stable release is 2.1.2.
Regards,
One Star

Re: tOracleOutputBulkExec commits

Thanks. I am using 2.1.2, but I had not tried your suggestion. I will do so this afternoon.