tOracleConnection doe snot use SERVICE_NAME

One Star

tOracleConnection doe snot use SERVICE_NAME

I'm working on Windows 7 64 bits, with TOS DI 5.4.1, Java JDK 1.6.1_43 and Oracle 11gR2
I have a problem with the configuration of tOracleConnection.
See the attached documents for the job settings.
I cannot use the features "Guess Query" or "Guess Schema" because of an Oracle error:

Database connection is failed.
java.lang.RuntimeException: java.sql.SQLException: Listener refused the connection with the following error:
ORA-12505, TNS:listener does not currently know of SID given in connect descriptor

at org.talend.core.model.metadata.builder.database.JDBCDriverLoader.getConnection(
at org.talend.core.model.metadata.builder.database.ExtractMetaDataUtils.connect(

When I set manually the schema of tOracleInput, the job correctly connect to the database and return the output of the query.
Please help!!!


Re: tOracleConnection doe snot use SERVICE_NAME

Did you use SID for Database value?
Can you make metadata oracle DB connection successfully?
Best regards
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: tOracleConnection doe snot use SERVICE_NAME

I used Service name.
I can make a successful metadata connection but the error is still there.
Seventeen Stars

Re: tOracleConnection doe snot use SERVICE_NAME

Mostly this happened if some context parameters are wrong. I work with Oracle 11g and Talend 5.4.1 and it works well - also the Guess Schema functionality.
You could change or inspect the used parameters if you click on Set parameter and continue
One Star

Re: tOracleConnection doe snot use SERVICE_NAME

The window "Configure Connection Parameters" complains about the empty string ("") AdditionalJDBC Parameters.
See attached screen.
What should i then put there?
Four Stars

Re: tOracleConnection doe snot use SERVICE_NAME



i know it's an old message but i have the same error with TOS DI 7.0.1 and a solution for it.

i guess you have a problem with DBInput Component or with some other component that uses an existing connection.

I had the same problem and i think it's a bug.

Here is the case :

I have a DB Connection component with Connection Type "Oracle Service Name"


When i put a DB Input Component in my project the default values are like these. ( Connection Type is "Oracle SID" )


When i check "use an existing connection" "Connection Type" and other values are gone because these value will be used from an existing connection ( That's what user thinks, but in real it's not true).

If you don't want to define the schema manually you can slect a table from the DB. But if you click the "..." button you get this error.


The solution is to uncheck "use an existing connection" and set "Connection Type" to "Oracle Service Name". Then check "use an existing connection" again, now it works.


Best wishes

Mustafa Yasar


Calling Talend Open Studio Users

The first 100 community members completing the Open Studio survey win a $10 gift voucher.

Start the survey


Talend named a Leader.

Get your copy


Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables


How Media Organizations Achieved Success with Data Integration

Learn how media organizations have achieved success with Data Integration


APIs for Dummies

View this on-demand webinar about APIs....

Watch Now