tMySqlSCD "WHERE AND" on Type 2 Transform

Four Stars

tMySqlSCD "WHERE AND" on Type 2 Transform

 Hello,

 

I'm attempting to set up a type 2 transform using the tMySql component. The following code is being generated, which causes errors when querying against the DB as it is invalid SQL (emphasis mine).

 

String updateSQLForType2_tMysqlSCD_1 = "UPDATE `"
+ tableName_tMysqlSCD_1
+ "` SET `scd_end` = ? WHERE AND `scd_end` IS NULL";

 

This seems like a consistent issue, I've tried in a few scenarios and all generate the same faulty code. I've tried dropping out to the java layer and modifying the generated code directly, although on an in-GUI compile the faulty code is regenerated. Is there any way to get around this?

Tags (1)
Moderator

Re: tMySqlSCD "WHERE AND" on Type 2 Transform

Hi,

Could you please indicate on which build version you got this issue? Screenshot of your job setting will be preferred.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog

How Media Organizations Achieved Success with Data Integration

Learn how media organizations have achieved success with Data Integration

Read

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch