Four Stars

tMicrosoftCRMInput error v2011 / v2016 odatas



I use TOS for DI v6.4.1


I tried 2 onlines connection :

  • v2011 with SOAP service
  • v2016 odata with REST service.

With v2016 odata (REST servce), we have the following error :


[pool-2-thread-1] INFO - [Correlation ID: null] Sent (null) Correlation Id is not same as received (null).
[pool-2-thread-1] INFO - [Correlation ID: xxxxxxxxxxxxxxxxx] Instance discovery was successful
[pool-2-thread-1] ERROR - [Correlation ID: xxxxxxxxxxxxxxxxxxxx] Request to acquire token failed. {"error_description":"AADSTS70001: Application with identifier 'xxxxxxxxxxxxx' was not found in the directory 


Also, I found that issue in Jira : It seems to be in relation with that error. Is the bug known and resolved ?



With v2011 (SOAP Service), we have the following error :


Exception in component tMicrosoftCrmInput_10 
org.apache.axis2.AxisFault: The server did not recognise the action which it received.
	at org.apache.axis2.handlers.addressing.AddressingInFaultHandler.invoke(

Also, with the same parameters I can read datas extracted from the discovery service :




Thank you for your help on one of the solution or both.





Re: tMicrosoftCRMInput error v2011 / v2016 odatas


This jira issue: has been fixed on V 6.4.1

Could you please also post your  tMicrosoftCRMInput component setting screenshots on forum which will be helpful for us to address your issue?

Note: Please mask your sensitive data.

Best regards



Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: tMicrosoftCRMInput error v2011 / v2016 odatas

Ok, the bug was fixed in 6.4.1 but it was reported in 6.4.1 and I also get it in 6.4.1. 


In my case it shows the errors but still returns data.


I get the same error in 7.0.1.


Maybe not actually fixed?