tMap filter is not working

Six Stars

tMap filter is not working

Hi,

 

I have tMap component for the XML extract. For some of the column/attribute filter works fine but for one of the column/attribute it is not.

Below is the filter condition.

row2.timeStamp.equals("2017-07-06T06:35:00.000000")

 

Could you please let me know if any issue?

Tags (1)
Eight Stars

Re: tMap filter is not working

What is the data type for the row2.timestamp in talend?
Six Stars

Re: tMap filter is not working

Hi, Data type is string. Originally it is on date on XML but due to parsing issue, I had to change it to string.
Eight Stars

Re: tMap filter is not working

Expression is fine. Can you verify incoming data?
Community Manager

Re: tMap filter is not working

This is definitely because your timestamp column does not hold "2017-07-06T06:35:00.000000". You need to use a tLogRow to see what the column actually holds. The tMap filtering is not broken, your filter is not matching the data it is filtering.

Six Stars

Re: tMap filter is not working

I found an alternative solution to this

Seven Stars

Re: tMap filter is not working

Hi Brawal,

 

Please share the solution in the forum, then it will be helpful for others too..

Thanks.

What’s New for Talend Spring ’19

Watch the recorded webinar!

Watch Now

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch

Downloads and Trials

Test drive Talend's enterprise products.

Downloads

Definitive Guide to Data Integration

Practical steps to developing your data integration strategy.

Download