tMap Issue - Fields Out of Order?

One Star

tMap Issue - Fields Out of Order?

I'm trying to add some additional fields to a tMap, I've added the fields to the appropriate schemas, but whyen I try to run the job I'm getting type conversion errors, not because I'm mapping to the wrong data types, but because while the data on the 'left' side of the tMap is as expected, on the 'right' side its mapping the data with an offset of the number of fields I've added. Even though I've added these fields to both schemas and set the mappings.

Is there a step I'm missing?

 

I'm mapping from mssql to salesforce, if that has any bearing.

Community Manager

Re: tMap Issue - Fields Out of Order?

Can you take a screenshot to show this? I am not entirely sure what you mean.

Highlighted
Eight Stars

Re: tMap Issue - Fields Out of Order?

Are you using the Automap tool? If your names on the input and output aren't identical, it will create new fields in the output table after the existing ones. I'm not sure if that's what you mean by "offset", but if so, make sure your names match, then run Automap again.

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 2

Part 2 of a series on Context Variables

Blog

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog