tMap - Die on error not working ?

Five Stars

tMap - Die on error not working ?

Hello All,

I'm using TOS version 7.0.1.

When in my tMap, I uncheck the "Die on error" option, it changes to yellow.
Then the OK button of the window isn't greyed but does nothing anymore.
The only option I have is to press Cancel.

After that, the setup contains a little 1 in a red circle and of course, no rejected output is available.

I have then to go check the die on error option (which is unchecked, even if I pressed Cancel)...

 

Can you please help me ? Is this a bug or am I missing anything ??

 

Thanks in advance,

Fred


Accepted Solutions
Five Stars

Re: tMap - Die on error not working ?

I have the same problem :

version.PNGSoftware versiontmap1.PNGtmap2.PNGI open the tmap propertiesI open the tmap properties.

 

tmap3.PNG

I uncheck the "Die on error" dialog box. If I try to click or enter on "ok" nothing happens, the message box doesn't close and I can only close it by clicking on the red close symbol or on "cancel".

 

tmap4.PNGA "1" appear on the properties box and there is no error reject table.

tmap5.PNGIf I open the properties again I can see that the "Die on error" box is unchecked and I still can't click on ok.

Five Stars

Re: tMap - Die on error not working ?

So it seems to be an error occurring only with the 7.0.1 version of TOS because when i use the 7.0.1 version the table is not there and if I try to use the 6.5.1 version, the table is showing up properly.

magicallyworking.PNG


All Replies
Thirteen Stars

Re: tMap - Die on error not working ?

@FRibadeau,can you share your job and tMap settings?

Manohar B
Forteen Stars TRF
Forteen Stars

Re: tMap - Die on error not working ?

Hi,

With previous verisons (I use 6.4.1), when you uncheck the tMap option "Die on error", you got the "1" in a red circle (as you explain) plus an new output called ErrorReject placed on top of existing output flow already in place.

If you don't have the same behaviour with 7.0.1, it sounds like a bug. 


TRF
Five Stars

Re: tMap - Die on error not working ?

Hi,

 

Thanks for your answer.

You're right, it must be a bug.

I can't click on OK and by clicking Cancel, it keeps the Die on error modification but does not create the ErrorReject Output.

Thanks anyway,

 

 

Moderator

Re: tMap - Die on error not working ?

Hello,

What's OS version are you using? Have you tried to restart your studio to see if it works?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: tMap - Die on error not working ?

I have the same problem :

version.PNGSoftware versiontmap1.PNGtmap2.PNGI open the tmap propertiesI open the tmap properties.

 

tmap3.PNG

I uncheck the "Die on error" dialog box. If I try to click or enter on "ok" nothing happens, the message box doesn't close and I can only close it by clicking on the red close symbol or on "cancel".

 

tmap4.PNGA "1" appear on the properties box and there is no error reject table.

tmap5.PNGIf I open the properties again I can see that the "Die on error" box is unchecked and I still can't click on ok.

Five Stars

Re: tMap - Die on error not working ?

So it seems to be an error occurring only with the 7.0.1 version of TOS because when i use the 7.0.1 version the table is not there and if I try to use the 6.5.1 version, the table is showing up properly.

magicallyworking.PNG

Four Stars

Re: tMap - Die on error not working ?

This is not solved, just noted as a bug.

 

It's still there on 7.1.1

 

Anyone know what is happening with this?

Four Stars

Re: tMap - Die on error not working ?

The following exception appears in the .log file when you click the OK button, which probably is supposed to do the Reject table output creation

!ENTRY org.eclipse.ui 4 0 2018-11-05 12:05:23.689
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NullPointerException
at org.talend.designer.mapper.ui.dialog.PropertySetDialog.okPressed(PropertySetDialog.java:454)
One Star

Re: tMap - Die on error not working ?

Hello, I have the same exact issue, exactly shown in the pictures.  Has this bug been reported?

This I feel is a major issue, as it prevents capturing error logs in Tmap, is there a alternative way to capture the error message and logs for the rejects? If so please post.

This bug exists in both 7.0 and 7.1 that I have seen, 6.5 and 6.3 there are no issues. 

 

Any help on this would be greatly appreciated, and if there is an alternative way to capture the error logs and records, please post. Thank you.