One Star

tLdapInput gets only 1 000 lines on my Active Diectory connection

Hello,
i use a tLdapInput to get all my accounts by domain from an active directory connection.
All is ok, but i only get 1 000 lines instead of the 9 000 in AD.
Is there a way to go get more lines with this component, please ?
Thanks for your help.
Best regards,
Eric.
6 REPLIES
Community Manager

Re: tLdapInput gets only 1 000 lines on my Active Diectory connection

Hello
Do you change the value of limit filed?
Best regads

shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: tLdapInput gets only 1 000 lines on my Active Diectory connection

Hi,
thanks for your answer.
I have changed the limit to 2 000 or more, but i didn't get more than 1 000 lines ...
Best regards,
Eric.
One Star

Re: tLdapInput gets only 1 000 lines on my Active Diectory connection

Hi,
I have read the AD has a limit of 1000 returned results per inquiry - this is what you are seeing.
There is a parameter 'MaxPageSize' which has a default of 1000 - can you get the owner of ldap to change this setting?
Otherwise you will need to find a way to loop requests. Suprised that the talend component does not allow this.
Community Manager

Re: tLdapInput gets only 1 000 lines on my Active Diectory connection

Hello All
See 5976
Best regards
shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: tLdapInput gets only 1 000 lines on my Active Diectory connection

Hi Shong,
thank you for your answer.
So, the only way to get more than 1 000 lines is to ask the AD admin to change the pagesizelimit ?
I will contact him but i don't know if it will be changed, because i work for a big company, and i don't think they will change it only for me ... Smiley Sad
I am trying to use another way of getting my informations in case it wouldn't be changed.
Thanks for your help.
Best regards,
Eric.
One Star

Re: tLdapInput gets only 1 000 lines on my Active Diectory connection

Select the Paging option in TLdapInput component and increase it to 1000 instead of 100(Default value)