One Star

tGreenplumGPLoad component gives gpload error

We are having issues while using the tGreenplumGPLoad component. The data file and control file is created correctly and the target table gets created successfully and also the Talend job ends with errorcode as 0 but a dialog box is displayed after which the job ends. The message displayed in dialog box is as below:
"See the logfile 'C:\Python25\dist\gpload.exe.log' for details"
And below is the error in the gpload.exe.log file:

"gpload was unable to import The PyGreSQL Python module (pg.py) - DLL load failed: The specified procedure could not be found."

However, python is correctly installed in my machine. The data does not get migrated.
Appreciate any help on this.

Thanks,
Hemant
3 REPLIES
Moderator

Re: tGreenplumGPLoad component gives gpload error

Hi,
What version do you used? Talend open studio for Data integration or Talend Enterprise studio for Data integration, sorry for the misunderstanding.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: tGreenplumGPLoad component gives gpload error

Hi Sabrina,
Thanks for a prompt reply! We are currently using Talend Open Studio 5.2.0 and it does have a tGreenplumGPLoad component. Actually when we started using this component, it was working fine with small tables, but since we tried it with a huge table of abt 80 crore rows, we are getting this kind of issue. We even re-installed the Greenplum client, Python & TOS, but to no avail.
Appreciate any response on this.
Thanks,
Hemant
One Star

Re: tGreenplumGPLoad component gives gpload error

Hi Sabina,
I have installed tgreenplum loader correctly. It is working fine from command line and able to upsert data 
However when I run from tsystem using command "cmd /c gpload.py -f gpload.yml" I get below error
Error -gpload was unable to import the pygresql python module (pg.py) dll load failed with error code 193
Please suggest solution
regards
Vinit