tGPGDecrypt

Highlighted
Four Stars usi
Four Stars

tGPGDecrypt

I am having an issue with tGPGDecrypt using the TAC. My job runs fine in the Studio, but not when scheduled through the TAC. The TAC runs the job successfully, but none of the decrypted files are created.
Please let me know if you could shed any light on this. I have also attached an image of the job.
I am using Talend 5.1.2 r90681

Thanks,
Joe
Five Stars

Re: tGPGDecrypt

Have a read through http://www.talendbyexample.com/talend-encryption-decryption-tgpgdecrypt-component-reference.html
The important thing to realise is that the tGPGDecrypt component does no more than execute the OS gpg command.
This means that you can debug it by calling your own script first. You can simply echo $* to see what Talend has sent.
Take a look at GPG binary path in basic settings; I think you're already setting this from your image.
You may even find it helpful to use a scrript wrapper to GPG anyway. Gives you more control for passing additional parameters, for example, --batch --yes --passphrase-fd etc.
In my experience, passing passphrase from Talend doesn't always work well as GPG in batch mode seems to prefer passphrase-fd 0. using --passphrase-fd 0 from a script is better.

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog

How Media Organizations Achieved Success with Data Integration

Learn how media organizations have achieved success with Data Integration

Read

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.

Download

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch