Five Stars

tFileOutputExcel

Hi...

 

Can any one help me - I am getting all column(data) in one column(tFileOutputExcel

3 ACCEPTED SOLUTIONS

Accepted Solutions
Six Stars

Re: tFileOutputExcel

Hi there,

 

This is almost certainly to do with your source data, rather than the tFileOutputExcel component.

 

Can you provide more information - specifically where your data comes from, and the components you're using?

 

If you could include a screen grab of your Talend job, that would also be useful.

 

Regards,

 

 

Chris

Five Stars

Re: tFileOutputExcel

Hi..1.jpg2.jpgSource data.jpg

Six Stars

Re: tFileOutputExcel

Hi there,

 

Assuming the file "Emp_1" shown in your Notepad screen grab is your input to the job via the tInputFileDelimited, then it appears to be a fixed position file, rather than a delimited one, and so you'll need to use a tFileInputPositional.

 

What's likely to be happening, is that the tFileInputDelimited isn't finding the character it expects to be separating the fields, and so the entire line will be interpreted as the EmpId field.

 

I'd recommend ticking the Customize option in the tFileInputPositional, as it gives you much more control, but from what I can see of your sample data, in this case you just need to specify the size of each column, and this could just be done in the Pattern field.

 

There is always the possibility that "Empt_1" is a tab delimited file, in which case you don't need to replace the tIputFileDelimited, only ensure that the Field Separator is set to "\t".

 

 

Regards,

 

 

Chris

4 REPLIES
Six Stars

Re: tFileOutputExcel

Hi there,

 

This is almost certainly to do with your source data, rather than the tFileOutputExcel component.

 

Can you provide more information - specifically where your data comes from, and the components you're using?

 

If you could include a screen grab of your Talend job, that would also be useful.

 

Regards,

 

 

Chris

Five Stars

Re: tFileOutputExcel

Hi..1.jpg2.jpgSource data.jpg

Six Stars

Re: tFileOutputExcel

Hi there,

 

Assuming the file "Emp_1" shown in your Notepad screen grab is your input to the job via the tInputFileDelimited, then it appears to be a fixed position file, rather than a delimited one, and so you'll need to use a tFileInputPositional.

 

What's likely to be happening, is that the tFileInputDelimited isn't finding the character it expects to be separating the fields, and so the entire line will be interpreted as the EmpId field.

 

I'd recommend ticking the Customize option in the tFileInputPositional, as it gives you much more control, but from what I can see of your sample data, in this case you just need to specify the size of each column, and this could just be done in the Pattern field.

 

There is always the possibility that "Empt_1" is a tab delimited file, in which case you don't need to replace the tIputFileDelimited, only ensure that the Field Separator is set to "\t".

 

 

Regards,

 

 

Chris

Five Stars

Re: tFileOutputExcel

Now Its Working..Tnx