tFileOutputDelimited with text enclosure only for type "String" (and not for Integer)

Four Stars

tFileOutputDelimited with text enclosure only for type "String" (and not for Integer)

Hello 
I want to make a CSV file with a tFileOutputDelimited with text enclosure only for type "String" (not for integer).
exemple:
12;"text2";"text3";15
45;"text4";"text25";12

In csv option I try 

escape_char : """

text_enclosure : "\""

 

But the result is wrong :

"12";"text2";"text3";"15"
"45";"text4";"text25";"12"

 

How can i do ?


Thanks 

Forteen Stars

Re: tFileOutputDelimited with text enclosure only for type "String" (and not for Integer)

there is no settings for this 

if it important, You can disable enclosure in tFileOutputDelimited settings and add them manually in tMap for all string columns

 

and, yes this feature would be useful to have in Talend

-----------

What’s New for Talend Spring ’19

Watch the recorded webinar!

Watch Now

Agile Data lakes & Analytics

Accelerate your data lake projects with an agile approach

Watch

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.

Download

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch